about summary refs log tree commit diff stats
path: root/flake/packages/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake/packages/default.nix')
-rw-r--r--flake/packages/default.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/flake/packages/default.nix b/flake/packages/default.nix
new file mode 100644
index 00000000..470ea05c
--- /dev/null
+++ b/flake/packages/default.nix
@@ -0,0 +1,40 @@
+{
+  nixos-generators,
+  defaultSpecialArgs,
+  pkgs,
+  shell-library,
+  ...
+}: {
+  iso = nixos-generators.nixosGenerate {
+    system = "x86_64-linux";
+    specialArgs = defaultSpecialArgs;
+    modules = [
+      ../../hosts/marduk
+    ];
+    format = "install-iso";
+  };
+  install = import ../../bootstrap/install {
+    inherit
+      pkgs
+      shell-library
+      ;
+  };
+  activate = import ../../bootstrap/activate {
+    inherit
+      pkgs
+      shell-library
+      ;
+  };
+  setup = import ../../bootstrap/setup {
+    inherit
+      pkgs
+      shell-library
+      ;
+  };
+  config_setup = import ../../bootstrap/config_setup {
+    inherit
+      pkgs
+      shell-library
+      ;
+  };
+}