about summary refs log tree commit diff stats
path: root/flake/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake/default.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/flake/default.nix b/flake/default.nix
index 16ae52c6..2c8d6f6b 100644
--- a/flake/default.nix
+++ b/flake/default.nix
@@ -41,6 +41,7 @@
       # my things
       shell_library
       sysLib
+      nixLib
       templates
       # modules
       home-manager
@@ -61,7 +62,7 @@
   };
 
   tests = import ../tests {
-    inherit pkgs nixpkgs_as_input myPkgs sysLib;
+    inherit pkgs nixpkgs_as_input myPkgs sysLib nixLib;
     inherit (pkgs) lib;
     extraModules = {
       termfilechooser = "${nixpkgs_open_prs.nixpkgs-tfc}/nixos/modules/config/xdg/portals/termfilechooser.nix";
@@ -80,7 +81,7 @@
 in {
   inherit nixosConfigurations;
   checks."${system}" =
-    nixLib.maybeMerge {
+    nixLib.warnMerge {
       inherit
         (self.packages."${system}")
         nvim