about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix57
1 files changed, 2 insertions, 55 deletions
diff --git a/flake.nix b/flake.nix
index cf251beb..9f39d330 100644
--- a/flake.nix
+++ b/flake.nix
@@ -3,58 +3,8 @@
 
   inputs = {
     # base
-    nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable"; # 7c9cc5a6e5d38010801741ac830a3f8fd667a7a0
-    nixpkgs-stable.url = "github:NixOS/nixpkgs/nixos-23.05"; # 5550a85a087c04ddcace7f892b0bdc9d8bb080c8
-
-    my_flake = {
-      url = "git+https://codeberg.org/soispha/nixos-config.git";
-      inputs = {
-        # HACK: This is a workaround to prevent a cyclic dependency, as this 'my_flake'
-        # can't follow itself. This would obviously cause weird bugs upon use, but, as
-        # 'my_flake' is only used in the nix-registry this should work <2023-10-22>
-        my_flake.follows = "agenix";
-
-        # My flake inputs {{{
-        agenix.follows = "agenix";
-        beautysh.follows = "beautysh";
-        crane.follows = "crane";
-        disko.follows = "disko";
-        flake-compat.follows = "flake-compat";
-        flake-utils.follows = "flake-utils";
-        flake_update.follows = "flake_update";
-        flake_version_update.follows = "flake_version_update";
-        generate_firefox_extensions.follows = "generate_firefox_extensions";
-        gitignore.follows = "gitignore";
-        grades.follows = "grades";
-        haumea.follows = "haumea";
-        home-manager.follows = "home-manager";
-        impermanence.follows = "impermanence";
-        lanzaboote.follows = "lanzaboote";
-        lf_rename.follows = "lf_rename";
-        neovim_config.follows = "neovim_config";
-        nixNeovim.follows = "nixNeovim";
-        nixNeovimPlugins.follows = "nixNeovimPlugins";
-        nixVim.follows = "nixVim";
-        nixos-generators.follows = "nixos-generators";
-        nixpkgs-stable.follows = "nixpkgs-stable";
-        nixpkgs.follows = "nixpkgs";
-        poetry2nix.follows = "poetry2nix";
-        pre-commit-hooks.follows = "pre-commit-hooks";
-        ragenix.follows = "ragenix";
-        river_init_lesser.follows = "river_init_lesser";
-        rust-overlay.follows = "rust-overlay";
-        serverphone.follows = "serverphone";
-        shell_library.follows = "shell_library";
-        strip_js_comments.follows = "strip_js_comments";
-        systems.follows = "systems";
-        templates.follows = "templates";
-        user_js.follows = "user_js";
-        video_pause.follows = "video_pause";
-        yambar_cpu.follows = "yambar_cpu";
-        yambar_memory.follows = "yambar_memory";
-        # }}}
-      };
-    };
+    nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
+    nixpkgs-stable.url = "github:NixOS/nixpkgs/nixos-23.05";
 
     # inputs for following
     systems = {
@@ -336,7 +286,6 @@
     # core
     self,
     nixpkgs,
-    my_flake,
     # modules
     home-manager,
     nixos-generators,
@@ -374,7 +323,6 @@
     });
     # FIXME: this `nixpkgs` misses the configs applied to the other one
     nixpkgs_as_input = nixpkgs;
-    my_flake_as_input = my_flake;
     outputs = import ./flake {
       inherit
         # core
@@ -383,7 +331,6 @@
         system
         sysLib
         nixpkgs_as_input
-        my_flake_as_input
         # modules
         
         home-manager