about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix29
1 files changed, 1 insertions, 28 deletions
diff --git a/flake.nix b/flake.nix
index 9f39d330..ed5470f7 100644
--- a/flake.nix
+++ b/flake.nix
@@ -48,14 +48,6 @@
         gitignore.follows = "gitignore";
       };
     };
-    nixNeovimPlugins = {
-      url = "github:nixNeovim/nixNeovimPlugins";
-      inputs = {
-        flake-utils.follows = "flake-utils";
-        nixpkgs.follows = "nixpkgs";
-        poetry2nix.follows = "poetry2nix";
-      };
-    };
     flake-compat = {
       url = "github:edolstra/flake-compat";
       flake = false;
@@ -93,23 +85,12 @@
         nixpkgs.follows = "nixpkgs";
       };
     };
-    nixNeovim = {
-      url = "github:nixNeovim/nixNeovim";
-      inputs = {
-        nixpkgs.follows = "nixpkgs";
-        haumea.follows = "haumea";
-        flake-utils.follows = "flake-utils";
-        home-manager.follows = "home-manager";
-        nixneovimplugins.follows = "nixNeovimPlugins";
-      };
-    };
     nixVim = {
       url = "github:nix-community/nixvim";
       inputs = {
         nixpkgs.follows = "nixpkgs";
         flake-utils.follows = "flake-utils";
         pre-commit-hooks.follows = "pre-commit-hooks";
-        beautysh.follows = "beautysh";
       };
     };
     agenix = {
@@ -162,10 +143,6 @@
     };
 
     # my configs
-    neovim_config = {
-      url = "git+https://codeberg.org/soispha/neovim-config.git";
-      flake = false;
-    };
     templates = {
       url = "git+https://codeberg.org/soispha/flake-templates.git";
       inputs = {
@@ -295,10 +272,8 @@
     serverphone,
     disko,
     lanzaboote,
-    nixNeovim,
     nixVim,
     # external dependencies
-    neovim_config,
     user_js,
     templates,
     # my binaries
@@ -319,7 +294,7 @@
     pkgs = import nixpkgs (import ./sys/nixpkgs {
       inherit (nixpkgs) lib;
       inherit system sysLib;
-      overlays = [nixNeovim.overlays.default];
+      overlays = [];
     });
     # FIXME: this `nixpkgs` misses the configs applied to the other one
     nixpkgs_as_input = nixpkgs;
@@ -334,7 +309,6 @@
         # modules
         
         home-manager
-        nixNeovim
         nixVim
         nixos-generators
         impermanence
@@ -345,7 +319,6 @@
         lanzaboote
         # external dependencies
         
-        neovim_config
         user_js
         templates
         # my binaries