about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 959eb8ed..e7906724 100644
--- a/flake.nix
+++ b/flake.nix
@@ -13,6 +13,10 @@
       url = "github:ryantm/agenix";
       inputs.nixpkgs.follows = "nixpkgs";
     };
+    ragenix = {
+      url = "github:yaxitech/ragenix";
+      inputs.nixpkgs.follows = "nixpkgs";
+    };
     impermanence = {
       url = "github:nix-community/impermanence";
     };
@@ -89,7 +93,6 @@
           "steam"
           "steam-original"
         ];
-
       inherit system;
     };
   in {
@@ -145,7 +148,7 @@
     };
     devShells."${system}" = {
       default = pkgs.mkShell {
-        packages = with pkgs; [nil alejandra statix];
+        packages = with pkgs; [nil alejandra statix inputs.ragenix.packages."${system}".default];
       };
     };
   };