about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix13
1 files changed, 8 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index e7906724..35fc36b2 100644
--- a/flake.nix
+++ b/flake.nix
@@ -88,11 +88,14 @@
     sysLib = import ./lib {inherit pkgs shell-library;};
     system = "x86_64-linux";
     pkgs = import inputs.nixpkgs {
-      config.allowUnfreePredicate = pkg:
-        builtins.elem (inputs.nixpkgs.lib.getName pkg) [
-          "steam"
-          "steam-original"
-        ];
+      config = {
+        contentAddressedByDefault = true;
+        config.allowUnfreePredicate = pkg:
+          builtins.elem (inputs.nixpkgs.lib.getName pkg) [
+            "steam"
+            "steam-original"
+          ];
+      };
       inherit system;
     };
   in {