about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix14
1 files changed, 3 insertions, 11 deletions
diff --git a/flake.nix b/flake.nix
index b8d9890e..466b7d01 100644
--- a/flake.nix
+++ b/flake.nix
@@ -72,6 +72,7 @@
     # modules
     impermanence,
     agenix,
+    ragenix,
     # external dependencies
     neovim_config,
     user_js,
@@ -87,22 +88,13 @@
   }: let
     sysLib = import ./lib {inherit pkgs shell-library;};
     system = "x86_64-linux";
-    pkgs = import nixpkgs {
-      config = {
-#contentAddressedByDefault = true;
-        config.allowUnfreePredicate = pkg:
-          builtins.elem (nixpkgs.lib.getName pkg) [
-            "steam"
-            "steam-original"
-          ];
-      };
-      inherit system;
-    };
+    pkgs = nixpkgs.legacyPackages.${system};
   in {
     nixosConfigurations = import ./flake/nixosConfigurations {
       inherit
         system
         pkgs
+        nixpkgs
         sysLib
         home-manager
         agenix