about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix19
1 files changed, 13 insertions, 6 deletions
diff --git a/flake.nix b/flake.nix
index 9c602019..58821993 100644
--- a/flake.nix
+++ b/flake.nix
@@ -3,6 +3,17 @@
   description = "Nixos system config";
 
   inputs = {
+    nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
+    home-manager = {
+      url = "github:nix-community/home-manager/master";
+      inputs.nixpkgs.follows = "nixpkgs";
+    };
+
+    agenix = {
+      url = "github:ryantm/agenix";
+      inputs.nixpkgs.follows = "nixpkgs";
+    };
+
     neovim_config = {
       url = "git+https://codeberg.org/ene/neovim-config.git";
       flake = false;
@@ -13,12 +24,6 @@
       inputs.nixpkgs.follows = "nixpkgs";
     };
 
-    nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
-    home-manager = {
-      url = "github:nix-community/home-manager/master";
-      inputs.nixpkgs.follows = "nixpkgs";
-    };
-
     user_js = {
       url = "github:arkenfox/user.js";
       flake = false;
@@ -37,6 +42,7 @@
     strip_js_comments,
     user_js,
     impermanence,
+    agenix,
     ...
   } @ inputs: {
     nixosConfigurations.Tiamat = nixpkgs.lib.nixosSystem rec {
@@ -44,6 +50,7 @@
       specialArgs = inputs;
       modules = [
         ./hosts/desktop/configuration.nix
+        agenix.nixosModules.default
 
         home-manager.nixosModules.home-manager
         {