about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 466b7d01..d1837b7f 100644
--- a/flake.nix
+++ b/flake.nix
@@ -88,7 +88,7 @@
   }: let
     sysLib = import ./lib {inherit pkgs shell-library;};
     system = "x86_64-linux";
-    pkgs = nixpkgs.legacyPackages.${system};
+    pkgs = import nixpkgs (import ./system/nixpkgs {inherit (nixpkgs) lib; inherit system;});
   in {
     nixosConfigurations = import ./flake/nixosConfigurations {
       inherit