about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 0ff5d4b4..dd44e2f4 100644
--- a/flake.nix
+++ b/flake.nix
@@ -3,10 +3,16 @@
   description = "Nixos system config";
 
   inputs = {
+    neovim_config = {
+      url = "git+https://codeberg.org/ene/neovim-config.git";
+      flake = false;
+    };
+
     strip_js_comments = {
       url = "git+https://codeberg.org/ene/strip_js_comments.git";
       inputs.nixpkgs.follows = "nixpkgs";
     };
+
     nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
     home-manager = {
       url = "github:nix-community/home-manager/master";
@@ -23,11 +29,12 @@
     self,
     nixpkgs,
     home-manager,
+    neovim_config,
     strip_js_comments,
     user_js,
     ...
   } @ inputs: {
-    nixosConfigurations.Tiamat = nixpkgs.lib.nixosSystem {
+    nixosConfigurations.Tiamat = nixpkgs.lib.nixosSystem rec {
       system = "x86_64-linux";
       specialArgs = inputs;
       modules = [
@@ -41,6 +48,8 @@
             extraSpecialArgs = {
               inherit strip_js_comments;
               inherit user_js;
+              inherit system;
+              inherit neovim_config;
             };
           };