about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 80f8bc35..b748e0aa 100644
--- a/flake.nix
+++ b/flake.nix
@@ -14,6 +14,10 @@
     nixpkgs-tfc.url = "github:soispha/nixpkgs/add-termfilechooser";
     nixpkgs-onlykey.url = "github:soispha/nixpkgs/fix-onlykey-agent";
 
+    library = {
+      url = "git+https://git.vhack.eu/vhack.eu/nix-library?ref=prime";
+    };
+
     # inputs for following
     nix-darwin = {
       url = "github:lnl7/nix-darwin";
@@ -192,6 +196,7 @@
       };
     };
     lanzaboote = {
+      # TODO: Subscribe to their update feed. <2024-12-18>
       url = "github:nix-community/lanzaboote/v0.4.1";
       inputs = {
         nixpkgs.follows = "nixpkgs-stable";
@@ -262,6 +267,7 @@
     nixpkgs-stable,
     nixpkgs-tfc,
     nixpkgs-onlykey,
+    library,
     # modules
     home-manager,
     nixos-generators,
@@ -285,7 +291,7 @@
     system = "x86_64-linux";
     sysLib = shell_library.lib.${system};
 
-    nixLib = import ./lib {};
+    inherit (library) nixLib;
 
     pkgsStable = nixpkgs-stable.legacyPackages.${system};
     pkgs = nixpkgs.legacyPackages.${system};