about summary refs log tree commit diff stats
path: root/system/users/default.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-21 17:18:38 +0100
committerene <ene@sils.li>2023-02-21 17:18:38 +0100
commitb472206de10b7eca76ab68e2b2ba9b261aca6edc (patch)
treec5cb3ba3d5eb9b604ad93e8c4dc241a5262ba3c1 /system/users/default.nix
parentFix(lf): Fixed script invocations (diff)
downloadnixos-config-b472206de10b7eca76ab68e2b2ba9b261aca6edc.tar.gz
nixos-config-b472206de10b7eca76ab68e2b2ba9b261aca6edc.zip
Fix(user): Add a real module and change passwords
Diffstat (limited to 'system/users/default.nix')
-rw-r--r--system/users/default.nix37
1 files changed, 26 insertions, 11 deletions
diff --git a/system/users/default.nix b/system/users/default.nix
index c24e0ad0..116a96be 100644
--- a/system/users/default.nix
+++ b/system/users/default.nix
@@ -1,18 +1,33 @@
+# vim: ts=2
 {
   config,
   pkgs,
+  lib,
   ...
-}: {
-  users = {
-    mutableUsers = false;
-    users.soispha = {
-      isNormalUser = true;
-      home = "/home/soispha";
-      createHome = true;
-      shell = pkgs.zsh;
-      initialHashedPassword = "$y$jFT$ONrCqZIJKB7engmfA4orD/$0GO58/wV5wrYWj0cyONhyujZPjFmbT0XKtx2AvXLG0B";
-      extraGroups = ["wheel"];
-      uid = 1000;
+}: let
+  cfg = config.soispha.users;
+in {
+  options.soispha.users = {
+# enable = lib.mkEnableOption (lib.mdDoc "users");
+    hashedPassword = lib.mkOption {
+      type = lib.types.str;
+      example = lib.literalExpression "$y$jFT$ONrCqZIJKB7engmfA4orD/$0GO58/wV5wrYWj0cyONhyujZPjFmbT0XKtx2AvXLG0B";
+      default = "$y$jFT$ONrCqZIJKB7engmfA4orD/$0GO58/wV5wrYWj0cyONhyujZPjFmbT0XKtx2AvXLG0B";
+      description = lib.mdDoc "Hashed password for the user";
+    };
+  };
+  config = {
+    users = {
+      mutableUsers = false;
+      users.soispha = {
+        isNormalUser = true;
+        home = "/home/soispha";
+        createHome = true;
+        shell = pkgs.zsh;
+        initialHashedPassword = cfg.hashedPassword;
+        extraGroups = ["wheel"];
+        uid = 1000;
+      };
     };
   };
 }