about summary refs log tree commit diff stats
path: root/system/users/default.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-25 15:49:30 +0100
committerene <ene@sils.li>2023-02-25 15:49:30 +0100
commit3a1eee297ac3205259f511e376701cf8f9c64a66 (patch)
tree5d0a6d538267cf5481fcd3bb869b3f97593c671b /system/users/default.nix
parentFix(nix): Use the system nixpkgs version (diff)
downloadnixos-config-3a1eee297ac3205259f511e376701cf8f9c64a66.tar.gz
nixos-config-3a1eee297ac3205259f511e376701cf8f9c64a66.zip
Fix(users): Use zsh as default shell again
Diffstat (limited to '')
-rw-r--r--system/users/default.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/system/users/default.nix b/system/users/default.nix
index 97cf2ee0..f68c35d3 100644
--- a/system/users/default.nix
+++ b/system/users/default.nix
@@ -17,13 +17,16 @@ in {
     };
   };
   config = {
+    # I was told, that this solves some nasty problems:
+    programs.zsh.enable = true;
+
     users = {
       mutableUsers = false;
       users.soispha = {
         isNormalUser = true;
         home = "/home/soispha";
         createHome = true;
-        # shell = pkgs.zsh;
+        shell = pkgs.zsh;
         initialHashedPassword = cfg.hashedPassword;
         extraGroups = [
           "wheel"