about summary refs log tree commit diff stats
path: root/system/sound/sound.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-01 21:33:11 +0100
committerene <ene@sils.li>2023-02-03 17:34:11 +0100
commit871d3f95963eac25765427ecca9a8e4812071439 (patch)
tree5dcf241ece31050cf0c74219852242abe504e068 /system/sound/sound.nix
parentBuild(flake): Added Flake.lock (diff)
downloadnixos-config-871d3f95963eac25765427ecca9a8e4812071439.tar.gz
nixos-config-871d3f95963eac25765427ecca9a8e4812071439.zip
Feat: Split the config apart
Diffstat (limited to 'system/sound/sound.nix')
-rw-r--r--system/sound/sound.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/system/sound/sound.nix b/system/sound/sound.nix
new file mode 100644
index 00000000..16dd4279
--- /dev/null
+++ b/system/sound/sound.nix
@@ -0,0 +1,18 @@
+{config, ...}: {
+  # Enable sound with pipewire.
+  sound.enable = true;
+  hardware.pulseaudio.enable = false;
+  security.rtkit.enable = true;
+  services.pipewire = {
+    enable = true;
+    alsa.enable = true;
+    alsa.support32Bit = true;
+    pulse.enable = true;
+    # If you want to use JACK applications, uncomment this
+    jack.enable = true;
+
+    # use the example session manager (no others are packaged yet so this is enabled by default,
+    # no need to redefine it in your config for now)
+    #media-session.enable = true;
+  };
+}