about summary refs log tree commit diff stats
path: root/system/services/snapper/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-05-17 21:33:42 +0200
committerSoispha <soispha@vhack.eu>2023-05-17 22:14:35 +0200
commit3052bd64d90562330599b80844c05c4739edf32b (patch)
tree8fe916ba20c1688d492ef8d572af5c271835b6a1 /system/services/snapper/default.nix
parentFix(system/boot): Remove deprecated version option (diff)
downloadnixos-config-3052bd64d90562330599b80844c05c4739edf32b.tar.gz
nixos-config-3052bd64d90562330599b80844c05c4739edf32b.zip
Fix(system/services/snapper): Use new option layout
Diffstat (limited to '')
-rw-r--r--system/services/snapper/default.nix73
1 files changed, 34 insertions, 39 deletions
diff --git a/system/services/snapper/default.nix b/system/services/snapper/default.nix
index 547ee3f5..87456f30 100644
--- a/system/services/snapper/default.nix
+++ b/system/services/snapper/default.nix
@@ -1,46 +1,41 @@
 # vim: ts=2
-{config, ...}: {
+{...}: {
   services.snapper = {
     configs = {
       srv = {
-        subvolume = "/srv";
-        fstype = "btrfs";
-        extraConfig = ''
-          # users and groups allowed to work with config
-          ALLOW_GROUPS="wheel"
-
-          # sync users and groups from ALLOW_USERS and ALLOW_GROUPS to .snapshots
-          # directory
-          SYNC_ACL="yes"
-
-
-          # run daily number cleanup
-          NUMBER_CLEANUP="no"
-
-          # limit for number cleanup
-          NUMBER_MIN_AGE="1800"
-          NUMBER_LIMIT="50"
-          NUMBER_LIMIT_IMPORTANT="10"
-
-
-          # create hourly snapshots
-          TIMELINE_CREATE="yes"
-
-          # cleanup hourly snapshots after some time
-          TIMELINE_CLEANUP="yes"
-
-          # limits for timeline cleanup
-          TIMELINE_MIN_AGE="1800"
-          TIMELINE_LIMIT_HOURLY="7"
-          TIMELINE_LIMIT_DAILY="3"
-          TIMELINE_LIMIT_WEEKLY="0"
-          TIMELINE_LIMIT_MONTHLY="0"
-          TIMELINE_LIMIT_YEARLY="0"
-
-
-          # cleanup empty pre-post-pairs
-          EMPTY_PRE_POST_CLEANUP="yes"
-        '';
+        SUBVOLUME = "/srv";
+        FSTYPE = "btrfs";
+        # users and groups allowed to work with config
+        ALLOW_GROUPS = ["wheel"];
+
+        # sync users and groups from ALLOW_USERS and ALLOW_GROUPS to .snapshots
+        # directory
+        SYNC_ACL = true;
+
+        # run daily number cleanup
+        NUMBER_CLEANUP = false;
+
+        # limit for number cleanup
+        NUMBER_MIN_AGE = 1800;
+        NUMBER_LIMIT = 50;
+        NUMBER_LIMIT_IMPORTANT = 10;
+
+        # create hourly snapshots
+        TIMELINE_CREATE = true;
+
+        # cleanup hourly snapshots after some time
+        TIMELINE_CLEANUP = true;
+
+        # limits for timeline cleanup
+        TIMELINE_MIN_AGE = 1800;
+        TIMELINE_LIMIT_HOURLY = 7;
+        TIMELINE_LIMIT_DAILY = 3;
+        TIMELINE_LIMIT_WEEKLY = 2;
+        TIMELINE_LIMIT_MONTHLY = 0;
+        TIMELINE_LIMIT_YEARLY = 2;
+
+        # cleanup empty pre-post-pairs
+        EMPTY_PRE_POST_CLEANUP = true;
       };
     };
   };