about summary refs log tree commit diff stats
path: root/system/services/nix/default.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-03-25 07:56:48 +0100
committerene <ene@sils.li>2023-03-25 07:56:48 +0100
commitf0d261b781d69b9380bb43a008131cb3db846af9 (patch)
treecd68a1d2e8005c421735be085428dcf18783ce01 /system/services/nix/default.nix
parentFeat(system/libvirtd): Add libvirtd support (diff)
downloadnixos-config-f0d261b781d69b9380bb43a008131cb3db846af9.tar.gz
nixos-config-f0d261b781d69b9380bb43a008131cb3db846af9.zip
Feat(system/services/nix): Add templates and short names
Diffstat (limited to '')
-rw-r--r--system/services/nix/default.nix11
1 files changed, 9 insertions, 2 deletions
diff --git a/system/services/nix/default.nix b/system/services/nix/default.nix
index 15c3a026..afd26fab 100644
--- a/system/services/nix/default.nix
+++ b/system/services/nix/default.nix
@@ -1,8 +1,9 @@
+# vim: ts=2
 {
   config,
   lib,
   pkgs,
-  nixpkgs,
+  inputs,
   ...
 }: {
   nix = {
@@ -10,7 +11,13 @@
     package = pkgs.nixVersions.stable;
     # this can't be in nix settings because of some "type error". See:
     # https://discourse.nixos.org/t/flakes-error-error-attribute-outpath-missing/18044
-    registry.nixpkgs.flake = nixpkgs;
+
+    registry = {
+      nixpkgs.flake = inputs.nixpkgs;
+      n.flake = inputs.nixpkgs;
+      t.flake = inputs.templates;
+    };
+
     gc = {
       automatic = true;
       dates = "weekly";