about summary refs log tree commit diff stats
path: root/system/services/nix/default.nix
diff options
context:
space:
mode:
authorene <ene@sils.com>2023-04-03 09:10:14 +0200
committerene <ene@sils.com>2023-04-03 09:10:14 +0200
commitb580a7879d08e9b93e675bff1969acfa4f08930d (patch)
treeb652bb88c37e7130ee49a85a95b42f0d80d703e9 /system/services/nix/default.nix
parentChore(flake): Update (diff)
downloadnixos-config-b580a7879d08e9b93e675bff1969acfa4f08930d.tar.gz
nixos-config-b580a7879d08e9b93e675bff1969acfa4f08930d.zip
Fix(system/services/nix): Use real names
Declaring things by their attribute name 'inputs', makes the lives of
linters and such exceptionally harder.
Diffstat (limited to '')
-rw-r--r--system/services/nix/default.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/system/services/nix/default.nix b/system/services/nix/default.nix
index afd26fab..28fc251f 100644
--- a/system/services/nix/default.nix
+++ b/system/services/nix/default.nix
@@ -3,7 +3,8 @@
   config,
   lib,
   pkgs,
-  inputs,
+  nixpkgs,
+  templates,
   ...
 }: {
   nix = {
@@ -13,9 +14,9 @@
     # https://discourse.nixos.org/t/flakes-error-error-attribute-outpath-missing/18044
 
     registry = {
-      nixpkgs.flake = inputs.nixpkgs;
-      n.flake = inputs.nixpkgs;
-      t.flake = inputs.templates;
+      nixpkgs.flake = nixpkgs;
+      n.flake = nixpkgs;
+      t.flake = templates;
     };
 
     gc = {