about summary refs log tree commit diff stats
path: root/system/packages/packages.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-01 21:33:11 +0100
committerene <ene@sils.li>2023-02-03 17:34:11 +0100
commit871d3f95963eac25765427ecca9a8e4812071439 (patch)
tree5dcf241ece31050cf0c74219852242abe504e068 /system/packages/packages.nix
parentBuild(flake): Added Flake.lock (diff)
downloadnixos-config-871d3f95963eac25765427ecca9a8e4812071439.tar.gz
nixos-config-871d3f95963eac25765427ecca9a8e4812071439.zip
Feat: Split the config apart
Diffstat (limited to 'system/packages/packages.nix')
-rw-r--r--system/packages/packages.nix86
1 files changed, 86 insertions, 0 deletions
diff --git a/system/packages/packages.nix b/system/packages/packages.nix
new file mode 100644
index 00000000..1acba85e
--- /dev/null
+++ b/system/packages/packages.nix
@@ -0,0 +1,86 @@
+{
+  config,
+  pkgs,
+  ...
+}: {
+  environment.systemPackages = with pkgs; [
+    (builtins.readFile ./packages.conf) # TODO could work
+  ];
+}
+# QEMU
+# TEX
+# {{{
+#adobe-source-han-sans-kr-fonts # Adobe Source Han Sans Subset OTF - Korean OpenType/CFF fonts
+#alsa-utils # Advanced Linux Sound Architecture - Utilities
+#element-desktop # Glossy Matrix collaboration client — desktop version.
+#gawk # GNU version of awk
+#gimp # GNU Image Manipulation Program
+#git-lfs # Git extension for versioning large files
+#gnome-epub-thumbnailer # Thumbnailer for EPub and MOBI books
+#gnumeric # A GNOME Spreadsheet Program
+#gpick # Advanced color picker written in C++ using GTK+ toolkit
+#gradle # Powerful build system for the JVM
+#groff # GNU troff text-formatting system
+#jre11-openjdk-headless # OpenJDK Java 11 headless runtime environment
+#klavaro # Free touch typing tutor program
+#lifeograph # Private journal, diary and note taking application
+#lynx # A text browser for the World Wide Web
+#man-db # A utility for reading man pages
+#networkmanager # Network connection manager and user applications
+#nss-mdns # glibc plugin providing host name resolution via mDNS
+#python-spotdl # Download your Spotify playlists and songs along with album art and metadata (from YouTube if a match is found).
+#python-xlsx2csv # xlsx to csv converter
+#ruff # An extremely fast Python linter, written in Rust
+#signal-desktop # Signal Private Messenger for Linux
+#slides # Terminal based presentation tool
+#torbrowser-launcher # Securely and easily download, verify, install, and launch Tor Browser in Linux
+#web-ext # A command line tool to help build, run, and test web extensions
+#wkhtmltopdf # Command line tools to render HTML into PDF and various image formats
+#xcursor-bluecurve # Redhat's Bluecurve X mouse cursor theme
+# XORG
+#xorg-docs # X.org documentations
+#xorg-font-util # X.Org font utilities
+#xorg-fonts-100dpi # X.org 100dpi fonts
+#xorg-fonts-75dpi # X.org 75dpi fonts
+#xorg-fonts-encodings # X.org font encoding files
+#xorg-iceauth # ICE authority file utility
+#xorg-mkfontscale # Create an index of scalable font files for X
+#xorg-server # Xorg X server
+#xorg-server-common # Xorg server common files
+#xorg-server-devel # Development files for the X.Org X server
+#xorg-server-xephyr # A nested X server that runs as an X application
+#xorg-server-xnest # A nested X server that runs as an X application
+#xorg-server-xvfb # Virtual framebuffer X server
+#xorg-sessreg # Register X sessions in system utmp/utmpx databases
+#xorg-setxkbmap # Set the keyboard using the X Keyboard Extension
+#xorg-smproxy # Allows X applications that do not support X11R6 session management to participate in an X11R6 session
+#xorg-x11perf # Simple X server performance benchmarker
+#xorg-xauth # X.Org authorization settings program
+#xorg-xbacklight # RandR-based backlight control application
+#xorg-xcmsdb # Device Color Characterization utility for X Color Management System
+#xorg-xcursorgen # Create an X cursor file from PNG images
+#xorg-xdpyinfo # Display information utility for X
+#xorg-xdriinfo # Query configuration information of DRI drivers
+#xorg-xev # Print contents of X events
+#xorg-xgamma # Alter a monitor's gamma correction
+#xorg-xhost # Server access control program for X
+#xorg-xinit # X.Org initialisation program
+#xorg-xinput # Small commandline tool to configure devices
+#xorg-xkbcomp # X Keyboard description compiler
+#xorg-xkbevd # XKB event daemon
+#xorg-xkbutils # XKB utility demos
+#xorg-xkill # Kill a client by its X resource
+#xorg-xlsatoms # List interned atoms defined on server
+#xorg-xlsclients # List client applications running on a display
+#xorg-xmodmap # Utility for modifying keymaps and button mappings
+#xorg-xpr # Print an X window dump from xwd
+#xorg-xrandr # Primitive command line interface to RandR extension
+#xorg-xrdb # X server resource database utility
+#xorg-xrefresh # Refresh all or part of an X screen
+#xorg-xsetroot # Classic X utility to set your root window background to a given pattern or color
+#xorg-xvinfo # Prints out the capabilities of any video adaptors associated with the display that are accessible through the X-Video extension
+#xorg-xwayland # run X clients under wayland
+#xorg-xwininfo # Command-line utility to print information about windows on an X server
+#xorg-xwud # X Window System image undumping utility
+# }}}
+