about summary refs log tree commit diff stats
path: root/system/packages/packages.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-02 19:17:31 +0100
committerene <ene@sils.li>2023-02-03 17:44:33 +0100
commit0378fa4f3023e98d587043f696e114445307bba4 (patch)
treeffaaebab0f600ea2b470418d109b87528eb7c63a /system/packages/packages.nix
parentFix(packages): Add a function to disassemble the set (diff)
downloadnixos-config-0378fa4f3023e98d587043f696e114445307bba4.tar.gz
nixos-config-0378fa4f3023e98d587043f696e114445307bba4.zip
Fix(packages): Archlinux names -> Nixos namesChanged the packages names from the arch ones to the Nixos ones
Diffstat (limited to '')
-rw-r--r--system/packages/packages.nix43
1 files changed, 20 insertions, 23 deletions
diff --git a/system/packages/packages.nix b/system/packages/packages.nix
index a0b47bf1..7df0adc7 100644
--- a/system/packages/packages.nix
+++ b/system/packages/packages.nix
@@ -7,7 +7,7 @@ with pkgs; let
 
     Browsers = [
       firefox # web browser
-      ungoogled-chromium-xdg-bin # web browser (only for web programming)
+      ungoogled-chromium # web browser (only for web programming)
     ];
 
     ImageManipulation = [
@@ -17,7 +17,7 @@ with pkgs; let
 
     Social = [
       mumble # voice chat software (client)
-      nheko-git # Matrix Desktop client
+      nheko # Matrix Desktop client
     ];
 
     Misc = [
@@ -52,15 +52,15 @@ with pkgs; let
     Backups = [
       rclone # Sync files to and from Google Drive, S3, Swift, Cloudfiles, Dropbox and Google Cloud Storage
       snapper # A tool for managing BTRFS and LVM snapshots. It can create, diff and restore snapshots and provides timelined auto-snapping.
-      snap-sync # Use snapper snapshots to backup to external drive
+      #snap-sync # Use snapper snapshots to backup to external drive
     ];
 
     Misc = [
       android-file-transfer # Android MTP client with minimalistic UI
-      docx2txt # Recovers text from DOCX files, with good formatting.
+      #python39Packages.docx2txt # Recovers text from DOCX files, with good formatting.
       btop # Interactive process viewer (maybe better than htop)
-      ttf-sourcecodepro-nerd # Patched font Source Code Pro from nerd fonts library
-      xdg-ninja-git # A shell script which checks your $HOME for unwanted files and directories.
+      nerdfonts # Patched font Source Code Pro from nerd fonts library
+      xdg-ninja # A shell script which checks your $HOME for unwanted files and directories.
       yokadi # Command line oriented, sqlite powered, todo list
     ];
 
@@ -79,7 +79,7 @@ with pkgs; let
         yambar # status panel
         swaybg # Wallpaper
         mako # notification daemon
-        bemenu-wayland # Run prompt
+        bemenu # Run prompt
       ];
 
       Media = [
@@ -100,7 +100,7 @@ with pkgs; let
 
       Functions = [
         broot # Fuzzy Search + tree + cd
-        dragon-drop # Simple drag-and-drop source/sink
+        xdragon # Simple drag-and-drop source/sink
         trash-cli # Command line trashcan (recycle bin) interface
       ];
 
@@ -156,10 +156,6 @@ with pkgs; let
         gutenprint # Top quality printer drivers for POSIX systems
         sane-airscan # SANE - SANE backend for AirScan (eSCL) and WSD document scanners
       ];
-
-      CPU = [
-        cpupower # examine and tune power saving related features of your processor
-      ];
     };
 
     Zsh = [
@@ -173,7 +169,7 @@ with pkgs; let
 
     CoreUtils = [
       file # File type identification utility
-      grep # A string search utility
+      #grep # A string search utility
       sudo # Give certain users the ability to run some commands as root
       wget # Network utility to retrieve files from the Web
       which # A utility to show the full path of commands
@@ -195,8 +191,8 @@ with pkgs; let
 
     Editors = [
       ed # A POSIX-compliant line-oriented text editor
-      sed # GNU stream editor
-      vi # The original ex/vi text editor
+      #sed # GNU stream editor
+      #vi # The original ex/vi text editor
       neovim # Fork of Vim aiming to improve user experience, plugins, and GUIs
     ];
 
@@ -220,16 +216,16 @@ with pkgs; let
 
       TeX = [
         zathura # Minimalistic document viewer
-        zathura-pdf-poppler # Adds pdf support to zathura by using the poppler engine
-        ltex-ls-bin # LTeX Language Server
+        #zathura-pdf-poppler # Adds pdf support to zathura by using the poppler engine
+        ltex-ls # LTeX Language Server
         biber # A Unicode-capable BibTeX replacement for biblatex users
         pandoc # Conversion between markup formats
       ];
 
       Web = [
-        vscode-langservers-extracted # Language servers extracted from VSCode.
-        dart-sass # Sass makes CSS fun again
-        prettier # An opinionated code formatter for JS, JSON, CSS, YAML and much more
+        nodePackages_latest.vscode-langservers-extracted # Language servers extracted from VSCode.
+        rsass # dart-sass # Sass makes CSS fun again
+        nodePackages_latest.prettier # An opinionated code formatter for JS, JSON, CSS, YAML and much more
       ];
 
       Shell = [
@@ -239,12 +235,12 @@ with pkgs; let
 
       Lua = [
         lua # Powerful lightweight programming language designed for extending applications
-        lua-format # LuaFormatter - Code formatter for Lua
-        lua-language-server # Lua Language Server coded by Lua
+        luaformatter # lua-format # LuaFormatter - Code formatter for Lua
+        sumneko-lua-language-server #lua-language-server # Lua Language Server coded by Lua
       ];
 
       R = [
-        r # Language and environment for statistical computing and graphics
+        R # Language and environment for statistical computing and graphics
       ];
     };
   };
@@ -360,3 +356,4 @@ in {
 #xorg-xwininfo # Command-line utility to print information about windows on an X server
 #xorg-xwud # X Window System image undumping utility
 # }}}
+