about summary refs log tree commit diff stats
path: root/system/fileSystemLayouts/default.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-17 16:58:36 +0100
committerene <ene@sils.li>2023-02-17 16:58:36 +0100
commit40b1887356b54bb5a2b3f7a613a9af1df2b6535f (patch)
tree7eb07f3260b44b3b42eefbecb7989ddd3123a4bc /system/fileSystemLayouts/default.nix
parentFix(users): Change home of soispha to /home/soispha (diff)
downloadnixos-config-40b1887356b54bb5a2b3f7a613a9af1df2b6535f.tar.gz
nixos-config-40b1887356b54bb5a2b3f7a613a9af1df2b6535f.zip
Fix(system): Rework some btrfs subvolume names and add lazyatime
The lazyatime mount setting should increase the performance somewhat, especially
because I don't really need atime. Thought using noatime might make this setting
completely useless, so it might get removed again.
Diffstat (limited to '')
-rw-r--r--system/fileSystemLayouts/default.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/system/fileSystemLayouts/default.nix b/system/fileSystemLayouts/default.nix
index a3ba353b..64ea4616 100644
--- a/system/fileSystemLayouts/default.nix
+++ b/system/fileSystemLayouts/default.nix
@@ -8,6 +8,7 @@ with lib; let
   defaultMountOptions = [
     "compress-force=zstd:15" # This saves disk space, at a performance cost
     "noatime" # should have some performance upsides, and I don't use it anyways
+    "lazytime" # make time changes in memory
   ];
 in {
   options.system.fileSystemLayouts = {
@@ -34,13 +35,13 @@ in {
       "/nix" = {
         device = cfg.mainDisk;
         fsType = "btrfs";
-        options = ["subvol=nix"] ++ defaultMountOptions;
+        options = ["subvol=nix-store"] ++ defaultMountOptions;
       };
       "/srv" = {
         device = cfg.mainDisk;
         fsType = "btrfs";
         neededForBoot = true;
-        options = ["subvol=storage"] ++ defaultMountOptions;
+        options = ["subvol=perstitend-storage"] ++ defaultMountOptions;
       };
       "/boot" = {
         device = cfg.efiDisk;