about summary refs log tree commit diff stats
path: root/sys/svcs/xdg/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-12-29 09:58:57 +0100
committerSoispha <soispha@vhack.eu>2023-12-29 09:58:57 +0100
commitd56282776b152399cd7ee00035de08a61efac8bf (patch)
treeb02ae139beeee2ed75667ed73cc8d9dc76fefc82 /sys/svcs/xdg/default.nix
parentfeat(hm/conf/xdg/url_handler): Also support opening in zathura (diff)
downloadnixos-config-d56282776b152399cd7ee00035de08a61efac8bf.tar.gz
nixos-config-d56282776b152399cd7ee00035de08a61efac8bf.zip
feat(sys/srvc/xdg/termfilechooser): Reactive
Diffstat (limited to 'sys/svcs/xdg/default.nix')
-rw-r--r--sys/svcs/xdg/default.nix36
1 files changed, 19 insertions, 17 deletions
diff --git a/sys/svcs/xdg/default.nix b/sys/svcs/xdg/default.nix
index 57d915b3..e2392213 100644
--- a/sys/svcs/xdg/default.nix
+++ b/sys/svcs/xdg/default.nix
@@ -7,35 +7,37 @@
   xdg = {
     portal = {
       enable = true;
-      # termfilechooser = {
-      #   enable = false;
-      #   settings = {
-      #     filechooser = {
-      #       cmd = "${sysLib.writeShellScriptWithLibraryAndKeepPath {
-      #         name = "lf_wrapper";
-      #         src = ./scripts/lf_wrapper;
-      #         dependencies = with pkgs; [
-      #           lf
-      #         ];
-      #       }}";
-      #     };
-      # };
-      # };
+      termfilechooser = {
+        enable = false;
+        settings = {
+          filechooser = {
+            cmd = "${sysLib.writeShellScriptWithLibraryAndKeepPath {
+              name = "lf_wrapper";
+              src = ./scripts/lf_wrapper;
+              dependencies = with pkgs; [
+                lf
+              ];
+            }}";
+          };
+        };
+      };
       config = {
         common = {
           # NOTE: The next entry is supposedly needed for gtk based apps <2023-08-31>
-          default = ["gtk"];
+          default = ["wlr" "gtk"];
+          "org.freedesktop.impl.portal.FileChooser" = ["termfilechooser"];
         };
 
         # TODO: Also activate, when on another wlr-based compositor <2023-11-25>
         river = {
-          default = ["wlr"];
+          default = ["wlr" "gtk"];
+          "org.freedesktop.impl.portal.FileChooser" = ["termfilechooser"];
         };
       };
       extraPortals = with pkgs; [
         xdg-desktop-portal-gtk
         xdg-desktop-portal-wlr
-        # xdg-desktop-portal-termfilechooser
+        xdg-desktop-portal-termfilechooser
       ];
     };
   };