about summary refs log tree commit diff stats
path: root/sys/svcs/xdg/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-12-29 13:05:13 +0100
committerSoispha <soispha@vhack.eu>2023-12-29 13:05:13 +0100
commit5c4f959e79583b0ce5c8870c4904a82f88d27d7f (patch)
tree8cc85a62f897c08810ae9ec52676ddb74bdd3f65 /sys/svcs/xdg/default.nix
parentfix(sys/svcs/xdg/portals): Set stdout and err debugging (diff)
downloadnixos-config-5c4f959e79583b0ce5c8870c4904a82f88d27d7f.tar.gz
nixos-config-5c4f959e79583b0ce5c8870c4904a82f88d27d7f.zip
fix(sys/svcs/xdg/portals): Add alacritty to the dependencies
Diffstat (limited to 'sys/svcs/xdg/default.nix')
-rw-r--r--sys/svcs/xdg/default.nix19
1 files changed, 9 insertions, 10 deletions
diff --git a/sys/svcs/xdg/default.nix b/sys/svcs/xdg/default.nix
index eede4455..60ee2a00 100644
--- a/sys/svcs/xdg/default.nix
+++ b/sys/svcs/xdg/default.nix
@@ -1,5 +1,6 @@
 {
   pkgs,
+  sysLib,
   ...
 }: {
   services.dbus.enable = true;
@@ -12,16 +13,14 @@
         settings = {
           filechooser = {
             default_dir = "/tmp";
-            cmd = let
-              nativeBuildInputs = with pkgs; [makeWrapper lf gawk coreutils mktemp dash fd gnugrep];
-            in "${pkgs.runCommandLocal "lf_wrapper" {
-                inherit nativeBuildInputs;
-              } ''
-                install -m755 ${./scripts/lf_wrapper} -D "$out/bin/lf_wrapper"
-                patchShebangs "$out/bin/lf_wrapper"
-                wrapProgram "$out/bin/lf_wrapper" --prefix PATH : ${pkgs.lib.makeBinPath nativeBuildInputs};
-                chown -R 1000:100 "$out/bin"
-              ''}/bin/lf_wrapper";
+            cmd = "${sysLib.writeShellScriptWithLibraryAndKeepPath {
+              src = ./scripts/lf_wrapper;
+              name = "lf_wrapper";
+              dependencies = with pkgs; [
+                lf
+                alacritty
+              ];
+            }}/bin/lf_wrapper";
           };
         };
       };