about summary refs log tree commit diff stats
path: root/sys/svcs/xdg/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2024-03-23 15:33:12 +0100
committerSoispha <soispha@vhack.eu>2024-03-23 15:33:12 +0100
commitbc388c1d27444b75aa8825f28f2caabfec26861d (patch)
treef55a83064e4b8d7eb57bc8d1f2239bc793934401 /sys/svcs/xdg/default.nix
parentfix(flake): Use new vendored `generate_firefox_extensions` binary (diff)
downloadnixos-config-bc388c1d27444b75aa8825f28f2caabfec26861d.tar.gz
nixos-config-bc388c1d27444b75aa8825f28f2caabfec26861d.zip
fix(flake): Import my modules stuck in nixpkgs prs directly
That makes it possible to use plain `nixpkgs-unstable` for the whole
system, whilst still using my unmerged modules and packages.
Diffstat (limited to '')
-rw-r--r--sys/svcs/xdg/default.nix15
1 files changed, 10 insertions, 5 deletions
diff --git a/sys/svcs/xdg/default.nix b/sys/svcs/xdg/default.nix
index 3229b97c..c3df9f60 100644
--- a/sys/svcs/xdg/default.nix
+++ b/sys/svcs/xdg/default.nix
@@ -1,8 +1,12 @@
 {
   pkgs,
+  nixpkgs_tfc,
   sysLib,
+  system,
   ...
-}: {
+}: let
+  pkgs_tfc = nixpkgs_tfc.legacyPackages."${system}";
+in {
   services.dbus.enable = true;
   xdg = {
     portal = {
@@ -10,6 +14,7 @@
       termfilechooser = {
         enable = true;
         logLevel = "TRACE";
+        package = pkgs_tfc.xdg-desktop-portal-termfilechooser;
         settings = {
           filechooser = {
             default_dir = "/tmp";
@@ -42,10 +47,10 @@
           "org.freedesktop.impl.portal.FileChooser" = ["termfilechooser"];
         };
       };
-      extraPortals = with pkgs; [
-        xdg-desktop-portal-gtk
-        xdg-desktop-portal-wlr
-        xdg-desktop-portal-termfilechooser
+      extraPortals = [
+        pkgs.xdg-desktop-portal-gtk
+        pkgs.xdg-desktop-portal-wlr
+        pkgs_tfc.xdg-desktop-portal-termfilechooser
       ];
     };
   };