about summary refs log tree commit diff stats
path: root/sys/boot/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
committerSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
commit3f600ab07dbad3b6dd7655587ddea158b19aea71 (patch)
tree7164ccd965e1d14ade970aeb8eb188b1442a6c91 /sys/boot/default.nix
parentStyle(treewide): Format all lua-files makes lua ➛ nix easier (diff)
downloadnixos-config-3f600ab07dbad3b6dd7655587ddea158b19aea71.tar.gz
nixos-config-3f600ab07dbad3b6dd7655587ddea158b19aea71.zip
Refactor(treewide): Abbreviate path names
Diffstat (limited to 'sys/boot/default.nix')
-rw-r--r--sys/boot/default.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys/boot/default.nix b/sys/boot/default.nix
new file mode 100644
index 00000000..9606c7b3
--- /dev/null
+++ b/sys/boot/default.nix
@@ -0,0 +1,41 @@
+{
+  pkgs,
+  lib,
+  ...
+}: {
+  boot = {
+    initrd = {
+      #compressor = "lz4";
+      #compressorArgs = ["-9"];
+      kernelModules = ["nvme" "btrfs"];
+    };
+
+    kernelPackages = pkgs.linuxPackages_latest;
+
+    lanzaboote = {
+      enable = true;
+      pkiBundle = "/etc/secureboot";
+    };
+
+    loader = {
+      # Lanzaboote currently replaces the systemd-boot module.
+      # This setting is usually set to true in configuration.nix
+      # generated at installation time. So we force it to false
+      # for now.
+      systemd-boot.enable = lib.mkForce false;
+
+      grub = {
+        enable = false;
+        # theme = pkgs.nixos-grub2-theme;
+        splashImage = ./boot_pictures/gnu.png;
+        efiSupport = true;
+        device = "nodev"; # only for efi
+      };
+
+      efi = {
+        canTouchEfiVariables = true;
+        efiSysMountPoint = "/boot";
+      };
+    };
+  };
+}