about summary refs log tree commit diff stats
path: root/services/nix/default.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-25 16:23:33 +0100
committerene <ene@sils.li>2023-02-25 16:23:33 +0100
commit1e2095ad8c1595c11255164d023efe2885a30831 (patch)
treeb02a67993c271da32f99d41d64d06b0dda712eb3 /services/nix/default.nix
parentFix(nix): Don't remove old gens so quickly (diff)
downloadnixos-config-1e2095ad8c1595c11255164d023efe2885a30831.tar.gz
nixos-config-1e2095ad8c1595c11255164d023efe2885a30831.zip
Fix(nix): Import the correct thing
Diffstat (limited to '')
-rw-r--r--services/nix/default.nix11
1 files changed, 6 insertions, 5 deletions
diff --git a/services/nix/default.nix b/services/nix/default.nix
index b86e46fe..15c3a026 100644
--- a/services/nix/default.nix
+++ b/services/nix/default.nix
@@ -2,10 +2,15 @@
   config,
   lib,
   pkgs,
-  inputs,
+  nixpkgs,
   ...
 }: {
   nix = {
+    # Flakes settings
+    package = pkgs.nixVersions.stable;
+    # this can't be in nix settings because of some "type error". See:
+    # https://discourse.nixos.org/t/flakes-error-error-attribute-outpath-missing/18044
+    registry.nixpkgs.flake = nixpkgs;
     gc = {
       automatic = true;
       dates = "weekly";
@@ -18,10 +23,6 @@
 
       keep-failed = true; #keep failed tmp build dirs
       pure-eval = true; # restrict file system and network access to  hash
-
-      # Flakes settings
-      package = pkgs.nixVersions.stable;
-      registry.nixpkgs.flake = inputs.nixpkgs;
     };
   };
 }