about summary refs log tree commit diff stats
path: root/pkgs/overlay.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:26:22 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:26:22 +0200
commit204731c0a69136c9cebcb54f1afecf5145e26bbe (patch)
treefc9132e5dc74e4a8e1327cdd411839a90f9410aa /pkgs/overlay.nix
parentrefactor(sys): Modularize and move to `modules/system` or `pkgs` (diff)
downloadnixos-config-204731c0a69136c9cebcb54f1afecf5145e26bbe.tar.gz
nixos-config-204731c0a69136c9cebcb54f1afecf5145e26bbe.zip
refactor(pkgs): Categorize into `by-name` shards
This might not be the perfect way to organize a package set --
especially if the set is not nearly the size of nixpkgs -- but it is
_at_ least a way of organization.
Diffstat (limited to '')
-rw-r--r--pkgs/overlay.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/pkgs/overlay.nix b/pkgs/overlay.nix
new file mode 100644
index 00000000..14d20fbd
--- /dev/null
+++ b/pkgs/overlay.nix
@@ -0,0 +1,16 @@
+# You can use this file as a nixpkgs overlay. This is useful in the
+# case where you don't want to add the whole NUR namespace to your
+# configuration.
+{sysLib}: self: super: let
+  nameValuePair = n: v: {
+    name = n;
+    value = v;
+  };
+  packages = import ./default.nix {
+    pkgs = super;
+    inherit sysLib;
+  };
+in
+  builtins.listToAttrs
+  (map (n: nameValuePair n packages.${n})
+    (builtins.attrNames packages))