about summary refs log tree commit diff stats
path: root/modules/home/pkgs/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-08-11 20:22:28 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-08-11 20:22:28 +0200
commit21f00a9f8d8d0a70764319e2a61ad7ee83be3d80 (patch)
tree0e3881654e00da433b9826e3fff507e58040e5f1 /modules/home/pkgs/default.nix
parentfix(home/beets): Use the `beetsExtraPlugins` from `pkgs` (diff)
downloadnixos-config-21f00a9f8d8d0a70764319e2a61ad7ee83be3d80.tar.gz
nixos-config-21f00a9f8d8d0a70764319e2a61ad7ee83be3d80.zip
fix(home/pkgs/{mpc-beetsrm, mpc-searchadd}): Propagate the overriden beets package
These packages need to use beets and should thus use the same beets
package as the internal module. This ensures, that plugins are
available.
Diffstat (limited to 'modules/home/pkgs/default.nix')
-rw-r--r--modules/home/pkgs/default.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/modules/home/pkgs/default.nix b/modules/home/pkgs/default.nix
index 4e77275d..e4c62b73 100644
--- a/modules/home/pkgs/default.nix
+++ b/modules/home/pkgs/default.nix
@@ -135,8 +135,14 @@ with pkgs; let
         ncmpc # mpd player client
         mpc-cli-man # a cli mpd client (added via a wrapper script)
         mpc # Wrapper around `mpc` that allows the usage of `mpc-{rm,lyrics,searchadd}` without the `-`
-        mpc-beetrm # Removes the currently playing song from the disk and storage
-        mpc-searchadd # Works like normal `mpc searchadd` but uses the `beets` query syntax
+        # Removes the currently playing song from the disk and storage
+        (mpc-beetrm.override {
+          beets = config.programs.beets.package;
+        })
+        # Works like normal `mpc searchadd` but uses the `beets` query syntax
+        (mpc-searchadd.override {
+          beets = config.programs.beets.package;
+        })
         # Displays the lyrics of the currently playing song
         (mpc-lyrics.override {
           mpd_music_dir = config.services.mpd.musicDirectory;