about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/lf/keybindings/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 21:56:16 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 21:59:59 +0200
commit746ea42ff4616024ec41b6dcb1d2588dee4b85d1 (patch)
tree4d4a1a774f6499161f7bd3077f1f21c31f93da35 /modules/home.legacy/conf/lf/keybindings/default.nix
parentrefactor(modules/legacy/conf/zsh): Parameterize and move to new `by-name` (diff)
downloadnixos-config-746ea42ff4616024ec41b6dcb1d2588dee4b85d1.tar.gz
nixos-config-746ea42ff4616024ec41b6dcb1d2588dee4b85d1.zip
refactor(modules/legacy/conf/lf): Move to new `by-name` dir
This makes it possible to mix and match between `NixOS` and
`home-manager` options and thus allows merging the secret handling
directly into this module. Furthermore, the `systemd` tempfiles handling
was also merged into this module.
Diffstat (limited to '')
-rw-r--r--modules/by-name/lf/lf/keybindings/default.nix (renamed from modules/home.legacy/conf/lf/keybindings/default.nix)4
1 files changed, 2 insertions, 2 deletions
diff --git a/modules/home.legacy/conf/lf/keybindings/default.nix b/modules/by-name/lf/lf/keybindings/default.nix
index b41004dc..b6feffe3 100644
--- a/modules/home.legacy/conf/lf/keybindings/default.nix
+++ b/modules/by-name/lf/lf/keybindings/default.nix
@@ -1,4 +1,4 @@
-{nixosConfig, ...}: {
+{uid}: {
   # Remove some defaults
   "'\"'" = null;
   ";" = null;
@@ -81,7 +81,7 @@
 
   # Movement
   gjr = "cd ~/.local/share/Trash/files";
-  gus = "cd /run/user/${builtins.toString nixosConfig.users.users.soispha.uid}";
+  gus = "cd /run/user/${builtins.toString uid}";
 
   gc = "cd ~/.config";
   gl = "cd ~/.local";