about summary refs log tree commit diff stats
path: root/hosts/lahmu/hardware/default.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-21 11:23:30 +0100
committerene <ene@sils.li>2023-02-21 11:23:30 +0100
commit976f90b793f27e4b38297753583c9f3cd24cd7cd (patch)
tree9ea16218a2d935435023eb837d93fc1747694218 /hosts/lahmu/hardware/default.nix
parentFix(bootstrap): Adapt to the new flake config (diff)
downloadnixos-config-976f90b793f27e4b38297753583c9f3cd24cd7cd.tar.gz
nixos-config-976f90b793f27e4b38297753583c9f3cd24cd7cd.zip
Feat(hosts): Add lahmu, a vm host
Diffstat (limited to 'hosts/lahmu/hardware/default.nix')
-rw-r--r--hosts/lahmu/hardware/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/hosts/lahmu/hardware/default.nix b/hosts/lahmu/hardware/default.nix
new file mode 100644
index 00000000..217a179d
--- /dev/null
+++ b/hosts/lahmu/hardware/default.nix
@@ -0,0 +1,29 @@
+{
+  config,
+  lib,
+  pkgs,
+  modulesPath,
+  ...
+}: {
+  imports = [
+    (modulesPath + "/installer/scan/not-detected.nix") # TODO is this necessary?
+    (modulesPath + "/profiles/qemu-guest.nix")
+    ./cpu.nix
+    ./gpu.nix
+  ];
+
+  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+
+  system.fileSystemLayouts = {
+    enable = true;
+    mainDisk = "/dev/disk/by-uuid/dfc66aa1-1530-4fbe-bc4f-205c6dc86ed9";
+    efiDisk = "/dev/disk/by-uuid/A1D1-D13F";
+  };
+
+  boot = {
+    kernelModules = ["kvm-amd"];
+
+    # TODO check this:
+    initrd.availableKernelModules = ["xhci_pci" "nvme" "rtsx_pci_sdmmc"];
+  };
+}