about summary refs log tree commit diff stats
path: root/hosts/apzu/hardware/gpu.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-04-21 09:19:38 +0200
committerSoispha <soispha@vhack.eu>2023-05-09 19:31:17 +0200
commit63410dbb2a6bcd29cdb264fd3ecbcfeb9d981ff1 (patch)
treeaf1f3c110b4a0267d040ec25e550e1147c9b846e /hosts/apzu/hardware/gpu.nix
parentBuild(update): Check for duplicates in flake.lock (diff)
downloadnixos-config-63410dbb2a6bcd29cdb264fd3ecbcfeb9d981ff1.tar.gz
nixos-config-63410dbb2a6bcd29cdb264fd3ecbcfeb9d981ff1.zip
Feat(host/apzu): Add
Diffstat (limited to '')
-rw-r--r--hosts/apzu/hardware/gpu.nix24
1 files changed, 17 insertions, 7 deletions
diff --git a/hosts/apzu/hardware/gpu.nix b/hosts/apzu/hardware/gpu.nix
index c3df51ae..180695e8 100644
--- a/hosts/apzu/hardware/gpu.nix
+++ b/hosts/apzu/hardware/gpu.nix
@@ -4,12 +4,22 @@
   lib,
   ...
 }: {
-  hardware.opengl.extraPackages = with pkgs; [
-    rocm-opencl-icd # open-cl
-    amdvlk # or directly through mesa
-    amd-media-driver # libva
-  ];
+  #   hardware.opengl.extraPackages = with pkgs; [
+  #     rocm-opencl-icd # open-cl
+  #     amdvlk # or directly through mesa
+  #     amd-media-driver # libva
+  #   ];
+  #
+  #   # Force radv, TODO is this logical?
+  #   environment.variables.AMD_VULKAN_ICD = "RADV";
 
-  # Force radv, TODO is this logical?
-  environment.variables.AMD_VULKAN_ICD = "RADV";
+  hardware.opengl = {
+    enable = true;
+    extraPackages = with pkgs; [
+      vaapiVdpau
+      libvdpau-va-gl
+
+      #amdvlk # or directly through mesa
+    ];
+  };
 }