about summary refs log tree commit diff stats
path: root/hosts/IDOHVE/hardware/filesystems.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-04 11:54:55 +0100
committerene <ene@sils.li>2023-02-04 11:55:56 +0100
commit75b442acb64bac70294681ae6d318a470afeac3c (patch)
treef05216df9e251e826188d4e8bfa6024af14078a4 /hosts/IDOHVE/hardware/filesystems.nix
parentFix(packages): Removed already by nixos managed ones (diff)
downloadnixos-config-75b442acb64bac70294681ae6d318a470afeac3c.tar.gz
nixos-config-75b442acb64bac70294681ae6d318a470afeac3c.zip
Feat: Made more configuration host independent
Diffstat (limited to '')
-rw-r--r--hosts/IDOHVE/hardware/filesystems.nix41
1 files changed, 0 insertions, 41 deletions
diff --git a/hosts/IDOHVE/hardware/filesystems.nix b/hosts/IDOHVE/hardware/filesystems.nix
deleted file mode 100644
index a188df18..00000000
--- a/hosts/IDOHVE/hardware/filesystems.nix
+++ /dev/null
@@ -1,41 +0,0 @@
-{config, ...}: let
-  main_disk = "/dev/disk/by-uuid/<uuid>";
-in {
-  fileSystems = {
-    "/" = {
-      device = "none";
-      fsType = "tmpfs";
-      options = ["defaults" "size=2G" "mode=755"];
-    };
-    "/nix" = {
-      device = main_disk;
-      fsType = "btrfs";
-      options = ["subvol=@nix" "compress-force=zstd:9"];
-    };
-    "/boot" = {
-      device = "/dev/disk/by-uuid/<uuid>";
-      fsType = "vfat";
-    };
-
-    "/srv/home" = {
-      device = main_disk;
-      fsType = "btrfs";
-      options = ["subvol=@home" "compress-force=zstd:9"];
-    };
-    "/srv/nixos-config" = {
-      device = main_disk;
-      fsType = "btrfs";
-      options = ["subvol=@nixos-config" "compress-force=zstd:9"];
-    };
-
-    "/etc/nixos" = {
-      device = "/srv/nix-config";
-      options = ["bind"];
-    };
-    "/home" = {
-      device = "/srv/home";
-      options = ["bind"];
-    };
-  };
-  swapDevices = [];
-}