about summary refs log tree commit diff stats
path: root/home-manager/packages/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-05-16 08:50:37 +0200
committerSoispha <soispha@vhack.eu>2023-05-16 08:50:37 +0200
commit340566fed8c3b0a905997b44022f6245e670d820 (patch)
treedf4b94b6f87739b520669f1ca1f0f3caa95adf1c /home-manager/packages/default.nix
parentFix(hm/conf/swaylock): Use correct mapping from path to string (diff)
downloadnixos-config-340566fed8c3b0a905997b44022f6245e670d820.tar.gz
nixos-config-340566fed8c3b0a905997b44022f6245e670d820.zip
Fix(hm/pkgs): Remove unused ones
Diffstat (limited to 'home-manager/packages/default.nix')
-rw-r--r--home-manager/packages/default.nix75
1 files changed, 14 insertions, 61 deletions
diff --git a/home-manager/packages/default.nix b/home-manager/packages/default.nix
index fa73373c..3d85568d 100644
--- a/home-manager/packages/default.nix
+++ b/home-manager/packages/default.nix
@@ -18,13 +18,13 @@ with pkgs; let
       alacritty # default terminal
     ];
     Browsers = [
-      ungoogled-chromium # web browser (only for web programming)
-      brave
+      #ungoogled-chromium # web browser (only for web programming)
+      #brave
     ];
 
     ImageManipulation = [
-      krita # new, and better (KDE)
-      gimp # conservative, and old (GNOME)
+      #krita # new, and better (KDE)
+      #gimp # conservative, and old (GNOME)
     ];
 
     Social = [
@@ -33,23 +33,23 @@ with pkgs; let
     ];
 
     Misc = [
-      kalzium # Periodic Table of Elements
+      #kalzium # Periodic Table of Elements
       keepassxc # password manager
-      onlykey # OnlyKey Chrome Desktop App
+      #onlykey # OnlyKey Chrome Desktop App
       anki-bin # spaced repetition
     ];
   };
 
   TuiCli = {
     EyeCandy = [
-      banner # Print large banners to ASCII terminals
+      #banner # Print large banners to ASCII terminals
       cmatrix # A curses-based scrolling 'Matrix'-like screen
       hyfetch # Neofetch with LGBTQ pride flags.
     ];
 
     Misc = [
       android-file-transfer # Android MTP client with minimalistic UI
-      xdg-ninja # A shell script which checks your $HOME for unwanted files and directories.
+      #xdg-ninja # A shell script which checks your $HOME for unwanted files and directories.
       xdg-utils # open urls and such things
       yokadi # Command line oriented, sqlite powered, todo list
       killall # kill a application by name
@@ -83,16 +83,16 @@ with pkgs; let
 
     Hardware = {
       Storage = [
-        #        compsize # Calculate compression ratio of a set of files on Btrfs
-        # TODO        smartmontools # Control and monitor S.M.A.R.T. enabled ATA and SCSI Hard Drives
+        #compsize # Calculate compression ratio of a set of files on Btrfs
+        # TODO smartmontools # Control and monitor S.M.A.R.T. enabled ATA and SCSI Hard Drives
       ];
 
       Input = [
-        piper # GTK application to configure gaming mice
+        #piper # GTK application to configure gaming mice
       ];
 
       Printer = [
-        # TODO        sane-airscan # SANE - SANE backend for AirScan (eSCL) and WSD document scanners
+        # TODO sane-airscan # SANE - SANE backend for AirScan (eSCL) and WSD document scanners
       ];
     };
 
@@ -114,58 +114,11 @@ with pkgs; let
       GeneralTools = [
         git # the fast distributed version control system
         glow # Command-line markdown renderer
-
-        # TODO ADD THESE TO A Shell-FLAKE        git-bug # Distributed, offline-first bug tracker embedded in git, with bridges
-        # TODO ADD THESE TO A Shell-FLAKE        strace # A diagnostic, debugging and instructional userspace tracer
-        # TODO ADD THESE TO A Shell-FLAKE        tokei # A blazingly fast CLOC (Count Lines Of Code) program
-        # TODO ADD THESE TO A Shell-FLAKE        onefetch # TODO
       ];
-
-      # TODO add to nix-shell      Rust = [
-      # TODO add to nix-shell        rustup # The Rust toolchain installer
-      # TODO add to nix-shell        rust-analyzer # Rust compiler front-end for IDEs
-      # TODO add to nix-shell      ];
-
-      # See above      Yaml = [
-      # See above        yamllint # Linter for YAML files
-      # See above      ];
-
-      # TODO See above TeX = [
-      # TODO See         zathura # Minimalistic document viewer
-      # TODO See         #zathura-pdf-poppler # Adds pdf support to zathura by using the poppler engine
-      # TODO See         ltex-ls # LTeX Language Server
-      # TODO See         biber # A Unicode-capable BibTeX replacement for biblatex users
-      # TODO See         pandoc # Conversion between markup formats
-      # TODO See       ];
-      # TODO See
-      # TODO See       Web = [
-      # TODO See         nodePackages_latest.vscode-langservers-extracted # Language servers extracted from VSCode.
-      # TODO See         rsass # dart-sass # Sass makes CSS fun again
-      # TODO See         nodePackages_latest.prettier # An opinionated code formatter for JS, JSON, CSS, YAML and much more
-      # TODO See       ];
-      # TODO See
-      # TODO See       Shell = [
-      # TODO See         dash # POSIX compliant shell that aims to be as small as possible
-      # TODO See         shellcheck # Shell script analysis tool
-      # TODO See       ];
-      # TODO See
-      # TODO See       Lua = [
-      # TODO See         lua # Powerful lightweight programming language designed for extending applications
-      # TODO See         luaformatter # lua-format # LuaFormatter - Code formatter for Lua
-      # TODO See         sumneko-lua-language-server #lua-language-server # Lua Language Server coded by Lua
-      # TODO See       ];
-      # TODO See
-      # TODO See       R = [
-      # TODO See         R # Language and environment for statistical computing and graphics
-      # TODO See       ];
     };
   };
-  #expect # A tool for automating interactive applications
-  #handlr # Powerful alternative to xdg-utils written in Rust
-  #packagekit-qt5 # Qt5 bindings for PackageKit
-  #vulkan-radeon # Radeon's Vulkan mesa driver
-  #xorg-bdftopcf # Convert X font from Bitmap Distribution Format to Portable Compiled Format
-
+  # TODO unmaintained, find sth else:
+  # handlr # Powerful alternative to xdg-utils written in Rust
   mapFun = x:
     if builtins.isAttrs x
     then