about summary refs log tree commit diff stats
path: root/home-manager/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-01 15:31:42 +0200
committerSoispha <soispha@vhack.eu>2023-08-01 15:42:54 +0200
commit0a608bd781dcda40144097b007fac0a0c60a8ee1 (patch)
treee69fbc1fd0e15e3b86f31f47b776df21f6f0170d /home-manager/default.nix
parentFix(hm/conf/gammastep): Use lighter settings on laptops (diff)
downloadnixos-config-0a608bd781dcda40144097b007fac0a0c60a8ee1.tar.gz
nixos-config-0a608bd781dcda40144097b007fac0a0c60a8ee1.zip
Refactor(treewide): Move module configuration in separate files
Diffstat (limited to 'home-manager/default.nix')
-rw-r--r--home-manager/default.nix87
1 files changed, 53 insertions, 34 deletions
diff --git a/home-manager/default.nix b/home-manager/default.nix
index 3779dbeb..0d1958f2 100644
--- a/home-manager/default.nix
+++ b/home-manager/default.nix
@@ -1,36 +1,55 @@
-{impermanence, ...}: let
-  # TODO actually use this in the user config
-  username = "soispha";
-  homeDirectory = "/home/${username}";
-
-  # xdg
-  configHome = "${homeDirectory}/.config";
-  dataHome = "${homeDirectory}/.local/share";
-  stateHome = "${homeDirectory}/.local/state";
-  cacheHome = "${homeDirectory}/.cache";
-  binHome = "${homeDirectory}/.local/bin";
-  # TODO add XDG_RUNTIME_DIR
-in {
-  imports = [
-    impermanence.nixosModules.home-manager.impermanence
-    #"${impermanence}/home-manager.nix"
-    ./impermanence
-    ./packages
-    ./config
-    ./wms
-    ./files
-  ];
-
-  # I don't know what this does, but I've seen it a lot online, so it should be good, right?
-  programs.home-manager.enable = true;
-
-  home = {
-    inherit username homeDirectory;
-    stateVersion = "23.05";
-    enableNixpkgsReleaseCheck = true;
-  };
-  xdg = {
-    inherit configHome dataHome stateHome cacheHome; #binHome; # TODO add binHome, when the standart is extended
-    enable = true;
+{
+  pkgs,
+  sysLib,
+  # extra information
+  system,
+  # bins
+  video_pause,
+  yambar_cpu,
+  yambar_memory,
+  strip_js_comments,
+  river_init_lesser,
+  grades,
+  shell_library,
+  flake_update,
+  # external deps
+  user_js,
+  neovim_config,
+  snap-sync,
+  # modules
+  impermanence,
+  ...
+}: {
+  home-manager = {
+    useGlobalPkgs = true;
+    useUserPackages = true;
+    users.soispha = import ./soispha;
+    extraSpecialArgs = {
+      inherit
+        pkgs
+        sysLib
+        # extra information
+        
+        system
+        # bins
+        
+        video_pause
+        yambar_cpu
+        yambar_memory
+        strip_js_comments
+        river_init_lesser
+        grades
+        shell_library
+        flake_update
+        # external deps
+        
+        user_js
+        neovim_config
+        snap-sync
+        # modules
+        
+        impermanence
+        ;
+    };
   };
 }