about summary refs log tree commit diff stats
path: root/home-manager/default.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-11 16:35:42 +0100
committerene <ene@sils.li>2023-02-11 16:35:42 +0100
commitc0ec18cbd4a4e49a94114414bbee3c8a747d8e13 (patch)
tree065f21635caee7c41f7fa67e101622c7ae063500 /home-manager/default.nix
parentFix: Rename host for clarity and import home-manager (diff)
downloadnixos-config-c0ec18cbd4a4e49a94114414bbee3c8a747d8e13.tar.gz
nixos-config-c0ec18cbd4a4e49a94114414bbee3c8a747d8e13.zip
Feat(home-manager): Make the home configuration better
Diffstat (limited to '')
-rw-r--r--home-manager/default.nix49
1 files changed, 34 insertions, 15 deletions
diff --git a/home-manager/default.nix b/home-manager/default.nix
index 54c29872..e6983ee4 100644
--- a/home-manager/default.nix
+++ b/home-manager/default.nix
@@ -5,26 +5,45 @@
   home-manager,
   inputs,
   ...
-}: {
+}: let
+  # TODO actually use this in the user config
+  username = "soispha";
+  homeDirectory = "/srv/home/${username}";
+  configHome = "${homeDirectory}/.config";
+in {
   imports = [
     home-manager.nixosModules.home-manager
 
-    ./alacritty
-    ./cups
-    ./firefox
-    ./gammastep
-    ./git
-    ./grades
-    ./gtk
-    ./keepassxc
-    ./latexindent
-    ./less
-    ./lf
-    ./mako
-    ./mpd
+        ./alacritty
+        ./cups
+        ./firefox
+        ./gammastep
+        ./git
+        ./grades
+        ./gtk
+        ./keepassxc
+        ./latexindent
+        ./less
+        ./lf
+        ./mako
+        ./mpd
   ];
 
   home-manager.users.soispha = {
-    home.packages = [];
+    home = {
+      inherit username homeDirectory;
+      stateVersion = "23.05";
+
+      # TODO
+      sessionVariables = {
+        DISPLAY = ":0";
+        EDITOR = "nvim";
+      };
+      packages = [];
+    };
+    xdg = {
+      inherit configHome;
+      enable = true;
+    };
   };
 }