about summary refs log tree commit diff stats
path: root/home-manager/config/mail/default.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-04-09 16:43:42 +0200
committerSoispha <soispha@vhack.eu>2023-04-09 21:20:43 +0200
commit313c8b54cbb5fb1543629c0301d6e509fcd800cd (patch)
tree74f6962a52a492a18e5a6bfa2edd508db860a618 /home-manager/config/mail/default.nix
parentDocs(TODO): Update (diff)
downloadnixos-config-313c8b54cbb5fb1543629c0301d6e509fcd800cd.tar.gz
nixos-config-313c8b54cbb5fb1543629c0301d6e509fcd800cd.zip
Feat(hm/conf): Add gpg support
Diffstat (limited to 'home-manager/config/mail/default.nix')
-rw-r--r--home-manager/config/mail/default.nix90
1 files changed, 46 insertions, 44 deletions
diff --git a/home-manager/config/mail/default.nix b/home-manager/config/mail/default.nix
index 31377b16..e44d2c33 100644
--- a/home-manager/config/mail/default.nix
+++ b/home-manager/config/mail/default.nix
@@ -1,49 +1,51 @@
-{...}: {
-  accounts.email.accounts = {
-    soispha = {
-      address = "soispha@vhack.eu";
-      #name = "soispha";
-      userName = "soispha";
-      realName = "Soispha";
-      primary = true;
-      passwordCommand = "secret-tool lookup account soispha@vhack.eu";
-      aliases = [
-        "admin@vhack.eu"
-      ];
-      folders = {
-      };
-      gpg = {
-        encryptByDefault = true;
-        key = ""; # TODO add
-        signByDefault = true;
-      };
-      signature = {
-        # TODO
-      };
-      neomutt = {
-        enable = true;
-      };
-      himalaya = {
-        enable = true;
-        backend = "imap";
-        sender = "smtp";
-        settings = {
+{config, ...}: {
+  accounts.email = {
+    maildirBasePath = "${config.xdg.dataHome}/maildir";
+    accounts = {
+      soispha = {
+        address = "soispha@vhack.eu";
+        userName = "soispha";
+        realName = "Soispha";
+        primary = true;
+        passwordCommand = "secret-tool lookup account soispha@vhack.eu";
+        aliases = [
+          "admin@vhack.eu"
+        ];
+        folders = {
+        };
+        gpg = {
+          encryptByDefault = true;
+          key = "9606FC749FCE16360723D4ADA5E94010C3A642AD";
+          signByDefault = true;
+        };
+        signature = {
           # TODO
         };
-      };
-      smtp = {
-        host = "smtp.vhack.eu";
-        port = 465;
-      };
-      imap = {
-        host = "imap.vhack.eu";
-        port = 993;
-      };
-      jmap = {
-        # TODO
-      };
-      maildir = {
-        path = "soispha";
+        neomutt = {
+          enable = true;
+        };
+        himalaya = {
+          enable = true;
+          backend = "imap";
+          sender = "smtp";
+          settings = {
+            # TODO
+          };
+        };
+        smtp = {
+          host = "smtp.vhack.eu";
+          port = 465;
+        };
+        imap = {
+          host = "imap.vhack.eu";
+          port = 993;
+        };
+        jmap = {
+          # TODO
+        };
+        maildir = {
+          path = "soispha";
+        };
       };
     };
   };