about summary refs log tree commit diff stats
path: root/home-manager/config/git/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-01 15:31:42 +0200
committerSoispha <soispha@vhack.eu>2023-08-01 15:42:54 +0200
commit0a608bd781dcda40144097b007fac0a0c60a8ee1 (patch)
treee69fbc1fd0e15e3b86f31f47b776df21f6f0170d /home-manager/config/git/default.nix
parentFix(hm/conf/gammastep): Use lighter settings on laptops (diff)
downloadnixos-config-0a608bd781dcda40144097b007fac0a0c60a8ee1.tar.gz
nixos-config-0a608bd781dcda40144097b007fac0a0c60a8ee1.zip
Refactor(treewide): Move module configuration in separate files
Diffstat (limited to 'home-manager/config/git/default.nix')
-rw-r--r--home-manager/config/git/default.nix76
1 files changed, 0 insertions, 76 deletions
diff --git a/home-manager/config/git/default.nix b/home-manager/config/git/default.nix
deleted file mode 100644
index 9e15da1d..00000000
--- a/home-manager/config/git/default.nix
+++ /dev/null
@@ -1,76 +0,0 @@
-{...}: let
-  gitIgnoreFile = ./git_ignore.git;
-  gitTemplateFile = ./git_template.git;
-in {
-  programs.git = {
-    enable = true;
-    #package = pkgs.gitAndTools.gitFull; # TODO for git send-email support
-    aliases = {
-      st = "status";
-      ds = "diff --staged";
-      di = "diff";
-      rs = "restore --staged";
-
-      ## Logging:
-      ls = "log --max-count=10 --color --format=format:'%C(bold red)%h%C(reset) %C(dim bold blue)%s%C(reset) %C(dim white)[%aN] %C(bold red)<%G?>%C(reset)%C(auto)%d%C(reset)'";
-
-      # https://stackoverflow.com/a/61487052
-      lg = "lg1";
-      lg1 = "lg1-specific --all";
-      lg2 = "lg2-specific --all";
-      lg3 = "lg3-specific --all";
-
-      lg1-specific = "log --graph --abbrev-commit --decorate \
-                      --format=format:'%C(bold blue)%h%C(reset) - %C(bold green)(%ar)%C(reset) %C(white)%s%C(reset) %C(dim white)- %an%C(reset)%C(bold cyan) [%G?]%C(reset)%C(auto)%d%C(reset)'";
-
-      lg2-specific = "log --graph --abbrev-commit --decorate \
-                      --format=format:'%C(bold blue)%h%C(reset) - %C(bold cyan)%aD%C(reset) %C(bold green)(%ar)%C(reset)%C(auto)%d%C(reset)%n''          %C(white)%s%C(reset) %C(dim white)- %an%C(reset)'";
-
-      lg3-specific = "log --graph --abbrev-commit --decorate \
-                      --format=format:'%C(bold blue)%h%C(reset)\
-                      - %C(bold cyan)%aD%C(reset) %C(bold green)(%ar)%C(reset)\
-                      %C(bold cyan)(committed: %cD)%C(reset) %C(auto)%d%C(reset)\
-                      %C(bold red)(signature: %G? by %GS, trust: %GT)%C(reset)%n\
-                      ''          %C(white)%s%C(reset)%n''\
-                      %C(dim white)- %an <%ae> %C(reset) %C(dim white)(committer: %cn <%ce>)%C(reset)\
-                      %C(bold white)- trailers: %(trailers) %C(reset)'";
-    };
-    extraConfig = {
-      core = {
-        excludesFile = "${gitIgnoreFile}";
-      };
-      init = {
-        defaultBranch = "prime";
-      };
-      user = {
-        email = "soispha@vhack.eu";
-        name = "Soispha";
-      };
-      help = {
-        autocorrect = 5;
-      };
-      push = {
-        gpgSign = "if-asked";
-      };
-      commit = {
-        template = "${gitTemplateFile}";
-      };
-    };
-    delta = {
-      enable = true;
-      options = {
-        decorations = {
-          commit-decoration-style = "bold yellow box ul";
-          file-decoration-style = "none";
-          file-style = "bold yellow ul";
-        };
-        features = "decorations";
-        whitespace-error-style = "22 reverse";
-      };
-    };
-    signing = {
-      key = "9606FC749FCE16360723D4ADA5E94010C3A642AD!";
-      signByDefault = true;
-    };
-  };
-}