about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-24 17:21:33 +0100
committerene <ene@sils.li>2023-02-24 17:21:33 +0100
commit386a1d9fb85fe163c7686ae8409eeca6f0ae89f3 (patch)
tree1d0a98116395fb3c285ce85b28ea90b91cef618e /flake.nix
parentFix(neovim): Use the right name for the config dir (diff)
downloadnixos-config-386a1d9fb85fe163c7686ae8409eeca6f0ae89f3.tar.gz
nixos-config-386a1d9fb85fe163c7686ae8409eeca6f0ae89f3.zip
Feat(bootstrap): Add nvim to the setup
This is still not very nixy, but I would like to have it just work right
now. But sure, this will (hopefully) get rewritten someday.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 24f6e5f1..bb54840d 100644
--- a/flake.nix
+++ b/flake.nix
@@ -89,6 +89,10 @@
         inherit pkgs;
         inherit (inputs) shell-library;
       };
+      config_setup = import ./bootstrap/config_setup {
+        inherit pkgs;
+        inherit (inputs) shell-library;
+      };
     };
 
     apps."${system}" = {
@@ -104,6 +108,10 @@
         type = "app";
         program = "${self.packages."${system}".setup}/bin/setup";
       };
+      config_setup = {
+        type = "app";
+        program = "${self.packages."${system}".config_setup}/bin/config_setup";
+      };
       default = self.apps."${system}".activate;
     };
   };