about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-04-10 10:58:33 +0200
committerSoispha <soispha@vhack.eu>2023-05-09 19:30:01 +0200
commit04e269a1e25ff8b75099f2113edee728d04429a8 (patch)
treef2fed6efd2938fb86b98681655395f1e42cbd790 /flake.nix
parentFeat(flake): Activate content-addressed derivations (diff)
downloadnixos-config-04e269a1e25ff8b75099f2113edee728d04429a8.tar.gz
nixos-config-04e269a1e25ff8b75099f2113edee728d04429a8.zip
Fix(treewide): Remove the reference to inputs
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix41
1 files changed, 28 insertions, 13 deletions
diff --git a/flake.nix b/flake.nix
index 35fc36b2..4d35926f 100644
--- a/flake.nix
+++ b/flake.nix
@@ -84,14 +84,14 @@
     yambar_cpu,
     grades,
     ...
-  } @ inputs: let
+  }: let
     sysLib = import ./lib {inherit pkgs shell-library;};
     system = "x86_64-linux";
-    pkgs = import inputs.nixpkgs {
+    pkgs = import nixpkgs {
       config = {
         contentAddressedByDefault = true;
         config.allowUnfreePredicate = pkg:
-          builtins.elem (inputs.nixpkgs.lib.getName pkg) [
+          builtins.elem (nixpkgs.lib.getName pkg) [
             "steam"
             "steam-original"
           ];
@@ -101,32 +101,47 @@
   in {
     nixosConfigurations = import ./flake/nixosConfigurations {
       inherit
-        inputs
         system
         pkgs
         sysLib
+        home-manager
+        agenix
+        impermanence
         river_init_lesser
         yambar_memory
         yambar_cpu
         grades
+        neovim_config
+        strip_js_comments
+        shell-library
+        user_js
+        snap-sync
         ;
     };
     packages."${system}" = {
       install = import ./bootstrap/install {
-        inherit pkgs;
-        inherit (inputs) shell-library;
+        inherit
+          pkgs
+          shell-library
+          ;
       };
       activate = import ./bootstrap/activate {
-        inherit pkgs;
-        inherit (inputs) shell-library;
+        inherit
+          pkgs
+          shell-library
+          ;
       };
       setup = import ./bootstrap/setup {
-        inherit pkgs;
-        inherit (inputs) shell-library;
+        inherit
+          pkgs
+          shell-library
+          ;
       };
       config_setup = import ./bootstrap/config_setup {
-        inherit pkgs;
-        inherit (inputs) shell-library;
+        inherit
+          pkgs
+          shell-library
+          ;
       };
     };
 
@@ -151,7 +166,7 @@
     };
     devShells."${system}" = {
       default = pkgs.mkShell {
-        packages = with pkgs; [nil alejandra statix inputs.ragenix.packages."${system}".default];
+        packages = with pkgs; [nil alejandra statix ragenix.packages."${system}".default];
       };
     };
   };