about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-04-05 17:01:17 +0200
committerene <ene@sils.li>2023-04-05 17:01:17 +0200
commit60742e6c892d76a6ae7667d3c072ebe88703b06f (patch)
tree314ab2a2fa64e81eecef41d287c07bc155cc00c4 /flake.nix
parentDocs(Todo): Update (diff)
downloadnixos-config-60742e6c892d76a6ae7667d3c072ebe88703b06f.tar.gz
nixos-config-60742e6c892d76a6ae7667d3c072ebe88703b06f.zip
Feat(Flake): Add nix develop support
Diffstat (limited to '')
-rw-r--r--flake.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 448a5724..cc8a7b73 100644
--- a/flake.nix
+++ b/flake.nix
@@ -137,5 +137,10 @@
       };
       default = self.apps."${system}".activate;
     };
+    devShells."${system}" = {
+      default = pkgs.mkShell {
+        packages = with pkgs; [nil alejandra statix];
+      };
+    };
   };
 }