about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-12-20 17:50:16 +0100
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-12-20 17:50:16 +0100
commit0ac11166a8fb22d1ce4de111f46e8a3ba1de7663 (patch)
tree25187cbc4273c69ca553dc0450b69fdfb9bea19a /flake.nix
parentfix(modules/lf): Always retry connecting to the server (diff)
downloadnixos-config-0ac11166a8fb22d1ce4de111f46e8a3ba1de7663.tar.gz
nixos-config-0ac11166a8fb22d1ce4de111f46e8a3ba1de7663.zip
refactor(lib): Upstream `lib` to vhack.eu
This allows to share it with the server config.
Diffstat (limited to '')
-rw-r--r--flake.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 80f8bc35..b748e0aa 100644
--- a/flake.nix
+++ b/flake.nix
@@ -14,6 +14,10 @@
     nixpkgs-tfc.url = "github:soispha/nixpkgs/add-termfilechooser";
     nixpkgs-onlykey.url = "github:soispha/nixpkgs/fix-onlykey-agent";
 
+    library = {
+      url = "git+https://git.vhack.eu/vhack.eu/nix-library?ref=prime";
+    };
+
     # inputs for following
     nix-darwin = {
       url = "github:lnl7/nix-darwin";
@@ -192,6 +196,7 @@
       };
     };
     lanzaboote = {
+      # TODO: Subscribe to their update feed. <2024-12-18>
       url = "github:nix-community/lanzaboote/v0.4.1";
       inputs = {
         nixpkgs.follows = "nixpkgs-stable";
@@ -262,6 +267,7 @@
     nixpkgs-stable,
     nixpkgs-tfc,
     nixpkgs-onlykey,
+    library,
     # modules
     home-manager,
     nixos-generators,
@@ -285,7 +291,7 @@
     system = "x86_64-linux";
     sysLib = shell_library.lib.${system};
 
-    nixLib = import ./lib {};
+    inherit (library) nixLib;
 
     pkgsStable = nixpkgs-stable.legacyPackages.${system};
     pkgs = nixpkgs.legacyPackages.${system};