about summary refs log tree commit diff stats
path: root/bootstrap/config_setup/default.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-24 17:21:33 +0100
committerene <ene@sils.li>2023-02-24 17:21:33 +0100
commit386a1d9fb85fe163c7686ae8409eeca6f0ae89f3 (patch)
tree1d0a98116395fb3c285ce85b28ea90b91cef618e /bootstrap/config_setup/default.nix
parentFix(neovim): Use the right name for the config dir (diff)
downloadnixos-config-386a1d9fb85fe163c7686ae8409eeca6f0ae89f3.tar.gz
nixos-config-386a1d9fb85fe163c7686ae8409eeca6f0ae89f3.zip
Feat(bootstrap): Add nvim to the setup
This is still not very nixy, but I would like to have it just work right
now. But sure, this will (hopefully) get rewritten someday.
Diffstat (limited to '')
-rw-r--r--bootstrap/config_setup/default.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/bootstrap/config_setup/default.nix b/bootstrap/config_setup/default.nix
new file mode 100644
index 00000000..7f4b6f2a
--- /dev/null
+++ b/bootstrap/config_setup/default.nix
@@ -0,0 +1,12 @@
+# vim: ts=2
+{
+  pkgs,
+  shell-library,
+  ...
+}: let
+  dependencies = with pkgs; [dash git];
+  name = "setup";
+  script = ./config_setup.sh;
+  lib = import ../../lib {inherit pkgs shell-library;};
+in
+  lib.makeShellScriptWithLibrary {inherit dependencies name script;}