about summary refs log tree commit diff stats
path: root/templates/unmaintained/python/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'templates/unmaintained/python/flake.nix')
-rw-r--r--templates/unmaintained/python/flake.nix67
1 files changed, 0 insertions, 67 deletions
diff --git a/templates/unmaintained/python/flake.nix b/templates/unmaintained/python/flake.nix
deleted file mode 100644
index 36c7478..0000000
--- a/templates/unmaintained/python/flake.nix
+++ /dev/null
@@ -1,67 +0,0 @@
-{
-  description = ""; # TODO: fill this out
-
-  inputs = {
-    nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
-    flake-utils.url = "github:numtide/flake-utils";
-
-    mach-nix.url = "github:davhau/mach-nix";
-  };
-
-  outputs = {
-    self,
-    nixpkgs,
-    mach-nix,
-    flake-utils,
-    ...
-  }: let
-    pythonVersion = "python39"; # TODO: update if necessary
-  in
-    flake-utils.lib.eachDefaultSystem (
-      system: let
-        pkgs = nixpkgs.legacyPackages.${system};
-        mach = mach-nix.lib.${system};
-
-        pythonApp = mach.buildPythonApplication ./.;
-        pythonAppEnv = mach.mkPython {
-          python = pythonVersion;
-          requirements = builtins.readFile ./requirements.txt;
-        };
-        pythonAppImage = pkgs.dockerTools.buildLayeredImage {
-          name = pythonApp.pname;
-          contents = [pythonApp];
-          config.Cmd = ["${pythonApp}/bin/main"];
-        };
-      in {
-        packages = {
-          image = pythonAppImage;
-          pythonPkg = pythonApp;
-
-          default = self.packages.pythonPkg;
-        };
-
-        apps.default = {
-          type = "app";
-          program = "${self.packages.pythonPkg}/bin/main";
-        };
-
-        devShells.default = pkgs.mkShell {
-          packages = with pkgs; [
-            pythonAppEnv
-            black
-            ruff
-            python310Packages.python-lsp-server
-            gnat
-          ];
-
-          env = {
-            LD_LIBRARY_PATH = pkgs.lib.makeLibraryPath [
-              pkgs.stdenv.cc.cc
-            ];
-
-            PYTHONPATH = "${pythonAppEnv}/bin/python";
-          };
-        };
-      }
-    );
-}