about summary refs log tree commit diff stats
path: root/templates/shell/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'templates/shell/flake.nix')
-rw-r--r--templates/shell/flake.nix88
1 files changed, 88 insertions, 0 deletions
diff --git a/templates/shell/flake.nix b/templates/shell/flake.nix
new file mode 100644
index 0000000..b699f25
--- /dev/null
+++ b/templates/shell/flake.nix
@@ -0,0 +1,88 @@
+{
+  description = ""; # TODO
+
+  inputs = {
+    nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
+    systems = {
+      url = "github:nix-systems/x86_64-linux"; # only evaluate for this system
+    };
+    flake-utils = {
+      url = "github:numtide/flake-utils";
+      inputs = {
+        systems.follows = "systems";
+      };
+    };
+    shell_library = {
+      url = "git+https://codeberg.org/soispha/shell_library.git";
+      inputs = {
+        flake-utils.follows = "flake-utils";
+        nixpkgs.follows = "nixpkgs";
+        systems.follows = "systems";
+      };
+    };
+    flake_version_update = {
+      url = "git+https://codeberg.org/soispha/flake_version_update.git";
+      inputs = {
+        systems.follows = "systems";
+        nixpkgs.follows = "nixpkgs";
+        flake-utils = "flake-utils";
+      };
+    };
+  };
+
+  outputs = {
+    self,
+    nixpkgs,
+    flake-utils,
+    shell_library,
+    flake_version_update,
+    ...
+  }:
+    flake-utils.lib.eachDefaultSystem (system: let
+      pkgs = nixpkgs.legacyPackages.${system};
+
+      built_script = shell_library.lib.${system}.writeShellScriptWithLibrary {
+        name = ""; # TODO
+        path = ./src/your_path; # TODO
+        dependencies = builtins.attrValues {inherit (pkgs) dash;};
+      };
+
+      # This version is set automatically on `cog bump --auto`;
+      version = "v1.0.0"; # GUIDING VERSION STRING
+    in {
+      packages.default = pkgs.stdenv.mkDerivation {
+        pname = ""; # TODO
+        inherit version;
+        src = ./.;
+
+        nativeBuildInputs = builtins.attrValues {
+          inherit
+            (pkgs)
+            #pandoc
+            
+            ;
+        };
+
+        buildPhase = ''
+          #mkdir --parents $out/docs;
+          #pandoc $src/docs/<name>.1.md -s -t man  > $out/docs/<name>.1
+        '';
+
+        installPhase = ''
+          install -D $out/docs/<name>.<man_number>  $out/share/man/man<man_number>/<name>;
+          install -D ${built_script}/bin/<name> $out/bin/<name>;
+        '';
+      };
+      app.default = {
+        type = "app";
+        program = "${self.packages.${system}.default}/bin/<name>";
+      };
+      devShells.default = pkgs.mkShell {
+        packages = with pkgs; [
+          flake_version_update.packages."${system}".default
+        ];
+      };
+    });
+}
+# vim: ts=2
+