about summary refs log tree commit diff stats
path: root/templates/c/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'templates/c/flake.nix')
-rw-r--r--templates/c/flake.nix16
1 files changed, 15 insertions, 1 deletions
diff --git a/templates/c/flake.nix b/templates/c/flake.nix
index cd4200c..e19bbd4 100644
--- a/templates/c/flake.nix
+++ b/templates/c/flake.nix
@@ -11,6 +11,15 @@
       };
     };
 
+    flake_version_update = {
+      url = "git+https://codeberg.org/soispha/flake_version_update.git";
+      inputs = {
+        systems.follows = "systems";
+        nixpkgs.follows = "nixpkgs";
+        flake-utils.follows = "flake-utils";
+      };
+    };
+
     # inputs for following
     systems = {
       url = "github:nix-systems/x86_64-linux"; # only evaluate for this system
@@ -32,6 +41,7 @@
     nixpkgs,
     flake-utils,
     treefmt-nix,
+    flake_version_update,
     ...
   }:
     flake-utils.lib.eachDefaultSystem (system: let
@@ -40,8 +50,9 @@
       nativeBuildInputs = with pkgs; [valgrind pandoc];
       treefmtEval = import ./treefmt.nix {inherit treefmt-nix pkgs;};
 
+      # This version is set automatically on `cog bump --auto`;
+      version = "v0.1.0"; # GUIDING VERSION STRING
       pname = "TODO";
-      version = "0.1";
 
       build = pkgs.stdenv.mkDerivation {
         inherit pname version;
@@ -61,6 +72,9 @@
       devShells.default = pkgs.mkShell {
         packages = with pkgs; [
           cocogitto
+          flake_version_update.packages."${system}".default
+
+          licensure
         ];
         inherit nativeBuildInputs;
         env = {