about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix43
1 files changed, 24 insertions, 19 deletions
diff --git a/flake.nix b/flake.nix
index 40557f3..5a85b1e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -36,36 +36,41 @@
     })
     // {
       templates = {
-        rust = {
-          path = ./rust;
-          description = "A Rust/Crane project";
-          welcomeText = "Please customize the text in the flake.nix and LICENSE.spdx files; Look at the TODO marks.\n Also run `git init`, `cargo init` and `cog install-hook commit-msg`";
-        };
-        c = {
-          path = ./c;
-          description = "A C project";
-          welcomeText = "Please customize the text in the flake.nix, LICENSE.spdx files and the Makefile BIN_NAME
-            variable; Look at the TODO marks.\n Also run `git init` and `cog install-hook commit-msg`";
-        };
+        # a b c d e f g h i j k l m n o p q r s t u v w x y z
         awk = {
           path = ./awk;
           description = "An Awk project";
           welcomeText = "Please customize the text in the flake.nix and LICENSE.spdx files; Look at the TODO marks.\n Also run `git init` and `cog install-hook commit-msg`";
         };
-        shell = {
-          path = ./shell;
-          description = "A Shell project";
-          welcomeText = "Please customize the text in the flake.nix and LICENSE.spdx files; Look at the TODO marks.\n Also run `git init` and `cog install-hook commit-msg`";
+        c = {
+          path = ./c;
+          description = "A C project";
+          welcomeText = "Please customize the text in the flake.nix, LICENSE.spdx files and the Makefile BIN_NAME variable; Look at the TODO marks.\n Also run `git init` and `cog install-hook commit-msg`";
+        };
+        latex = {
+          path = ./latex;
+          description = "A LaTeX project";
+          welcomeText = "Please customize the text in the flake.nix and LICENSE.spdx files; Look at the TODO marks.\n Also run `git init` and `cog install-hook commit-msg` and look at `lpm`";
         };
         markdown = {
           path = ./markdown;
           description = "A Markdown project";
           welcomeText = "Please customize the text in the flake.nix and LICENSE.spdx files; Look at the TODO marks.\n Also run `git init` and `cog install-hook commit-msg`";
         };
-        latex = {
-          path = ./latex;
-          description = "A LaTeX project";
-          welcomeText = "Please customize the text in the flake.nix and LICENSE.spdx files; Look at the TODO marks.\n Also run `git init` and `cog install-hook commit-msg` and look at `lpm`";
+        python = {
+          path = ./python;
+          description = "A Python project";
+          welcomeText = "Please customize the text in the flake.nix, LICENSE.spdx and setup.cfg files; Look at the TODO marks.\n Also run `git init` and `cog install-hook commit-msg`";
+        };
+        rust = {
+          path = ./rust;
+          description = "A Rust/Crane project";
+          welcomeText = "Please customize the text in the flake.nix and LICENSE.spdx files; Look at the TODO marks.\n Also run `git init`, `cargo init` and `cog install-hook commit-msg`";
+        };
+        shell = {
+          path = ./shell;
+          description = "A Shell project";
+          welcomeText = "Please customize the text in the flake.nix and LICENSE.spdx files; Look at the TODO marks.\n Also run `git init` and `cog install-hook commit-msg`";
         };
       };
     };