about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix61
1 files changed, 16 insertions, 45 deletions
diff --git a/flake.nix b/flake.nix
index 5a85b1e..ba19638 100644
--- a/flake.nix
+++ b/flake.nix
@@ -14,66 +14,37 @@
     systems = {
       url = "github:nix-systems/x86_64-linux"; # only evaluate for this system
     };
+    treefmt-nix = {
+      url = "github:numtide/treefmt-nix";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+      };
+    };
   };
 
   outputs = {
+    self,
     nixpkgs,
     flake-utils,
+    treefmt-nix,
     ...
-  }:
+  }: let
+    templates = import ./templates.nix {inherit (nixpkgs) lib;};
+  in
     flake-utils.lib.eachDefaultSystem (system: let
       pkgs = nixpkgs.legacyPackages."${system}";
+      treefmtEval = import ./treefmt.nix {inherit treefmt-nix pkgs;};
     in {
       devShells.default = pkgs.mkShell {
         packages = with pkgs; [
-          nil
-          alejandra
-          statix
-          ltex-ls
           cocogitto
         ];
       };
+
+      checks.formatting = treefmtEval.config.build.check self;
+      formatter = treefmtEval.config.build.wrapper;
     })
-    // {
-      templates = {
-        # a b c d e f g h i j k l m n o p q r s t u v w x y z
-        awk = {
-          path = ./awk;
-          description = "An Awk project";
-          welcomeText = "Please customize the text in the flake.nix and LICENSE.spdx files; Look at the TODO marks.\n Also run `git init` and `cog install-hook commit-msg`";
-        };
-        c = {
-          path = ./c;
-          description = "A C project";
-          welcomeText = "Please customize the text in the flake.nix, LICENSE.spdx files and the Makefile BIN_NAME variable; Look at the TODO marks.\n Also run `git init` and `cog install-hook commit-msg`";
-        };
-        latex = {
-          path = ./latex;
-          description = "A LaTeX project";
-          welcomeText = "Please customize the text in the flake.nix and LICENSE.spdx files; Look at the TODO marks.\n Also run `git init` and `cog install-hook commit-msg` and look at `lpm`";
-        };
-        markdown = {
-          path = ./markdown;
-          description = "A Markdown project";
-          welcomeText = "Please customize the text in the flake.nix and LICENSE.spdx files; Look at the TODO marks.\n Also run `git init` and `cog install-hook commit-msg`";
-        };
-        python = {
-          path = ./python;
-          description = "A Python project";
-          welcomeText = "Please customize the text in the flake.nix, LICENSE.spdx and setup.cfg files; Look at the TODO marks.\n Also run `git init` and `cog install-hook commit-msg`";
-        };
-        rust = {
-          path = ./rust;
-          description = "A Rust/Crane project";
-          welcomeText = "Please customize the text in the flake.nix and LICENSE.spdx files; Look at the TODO marks.\n Also run `git init`, `cargo init` and `cog install-hook commit-msg`";
-        };
-        shell = {
-          path = ./shell;
-          description = "A Shell project";
-          welcomeText = "Please customize the text in the flake.nix and LICENSE.spdx files; Look at the TODO marks.\n Also run `git init` and `cog install-hook commit-msg`";
-        };
-      };
-    };
+    // {inherit templates;};
 }
 # vim: ts=2