about summary refs log tree commit diff stats
path: root/c/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'c/flake.nix')
-rw-r--r--c/flake.nix54
1 files changed, 0 insertions, 54 deletions
diff --git a/c/flake.nix b/c/flake.nix
deleted file mode 100644
index 0eab217..0000000
--- a/c/flake.nix
+++ /dev/null
@@ -1,54 +0,0 @@
-{
-  description = "<Project description>";
-
-  inputs = {
-    nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
-
-    # inputs for following
-    systems = {
-      url = "github:nix-systems/x86_64-linux"; # only evaluate for this system
-    };
-    flake-compat = {
-      url = "github:edolstra/flake-compat";
-      flake = false;
-    };
-    flake-utils = {
-      url = "github:numtide/flake-utils";
-      inputs = {
-        systems.follows = "systems";
-      };
-    };
-  };
-
-  outputs = {
-    self,
-    nixpkgs,
-    flake-utils,
-    ...
-  }:
-    flake-utils.lib.eachDefaultSystem (system: let
-      pkgs = nixpkgs.legacyPackages."${system}";
-
-      nativeBuildInputs = with pkgs; [valgrind];
-    in {
-      packages.default = pkgs.stdenv.mkDerivation {
-        src = ./.;
-        pname = "<pkgs_name>";
-        version = "0.1";
-        makeFlags = ["PREFIX=${placeholder "out"}"];
-        inherit nativeBuildInputs;
-      };
-      apps.default = {
-        type = "app";
-        program = "${self.packages.${system}.default}/bin/<pkgs_name>";
-      };
-      devShells.default = pkgs.mkShell {
-        packages = with pkgs; [
-          cocogitto
-        ];
-        inherit nativeBuildInputs;
-      };
-    });
-}
-# vim: ts=2
-