about summary refs log tree commit diff stats
path: root/templates/unmaintained/nannou/shell.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-04-01 12:54:37 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-04-01 12:54:37 +0200
commit08eb5c464906a29e9f5135e1fb11e872b93746b1 (patch)
treec1cbbeade93e8d74009273e51e9fb9744bcf3d0a /templates/unmaintained/nannou/shell.nix
parentdocs(update_common_files): Improve terminal output (diff)
downloadflake-templates-08eb5c464906a29e9f5135e1fb11e872b93746b1.tar.gz
flake-templates-08eb5c464906a29e9f5135e1fb11e872b93746b1.zip
refactor(templates/unmaintained): Move out of the templates dir
Otherwise, the `update_common_files` script will try to instantiate
files in there, which is just useless noise.
Diffstat (limited to 'templates/unmaintained/nannou/shell.nix')
-rw-r--r--templates/unmaintained/nannou/shell.nix25
1 files changed, 0 insertions, 25 deletions
diff --git a/templates/unmaintained/nannou/shell.nix b/templates/unmaintained/nannou/shell.nix
deleted file mode 100644
index 6c4550a..0000000
--- a/templates/unmaintained/nannou/shell.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-#  A Creative Coding Framework for Rust.
-{
-  pkgs ? import <nixpkgs> {},
-  extraPkgs ? [],
-}:
-pkgs.mkShell {
-  buildInputs = with pkgs;
-    [
-      cargo
-      rustc
-      pkg-config
-      alsa-lib
-      cmake
-      openssl
-      xorg.libxcb
-    ]
-    ++ extraPkgs;
-  LD_LIBRARY_PATH = pkgs.lib.makeLibraryPath (with pkgs; [
-    xorg.libX11
-    xorg.libXcursor
-    xorg.libXrandr
-    xorg.libXi
-    vulkan-loader
-  ]);
-}