about summary refs log tree commit diff stats
path: root/templates/c/flake.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-04-02 13:44:56 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-04-02 13:44:56 +0200
commit10948ed35a04d6cbe05819acf9903e5e7395375b (patch)
treee5b57b6ef3aec62686d087969d9ed441209f7751 /templates/c/flake.nix
parentfix(templates.nix): Adjust to the new `init` script (diff)
downloadflake-templates-10948ed35a04d6cbe05819acf9903e5e7395375b.tar.gz
flake-templates-10948ed35a04d6cbe05819acf9903e5e7395375b.zip
feat(treewide): Also remove hard-coded values in the `templates/` dir
Diffstat (limited to 'templates/c/flake.nix')
-rw-r--r--templates/c/flake.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/templates/c/flake.nix b/templates/c/flake.nix
index a211b56..fea015c 100644
--- a/templates/c/flake.nix
+++ b/templates/c/flake.nix
@@ -51,14 +51,14 @@
       treefmtEval = import ./treefmt.nix {inherit treefmt-nix pkgs;};
 
       # This version is set automatically on `cog bump --auto`;
-      version = "v0.1.0"; # GUIDING VERSION STRING
-      pname = "TODO";
+      version = "v%INIT_APPLICATION_VERSION"; # GUIDING VERSION STRING
+      pname = "%INIT_APPLICATION_NAME";
 
       build = pkgs.stdenv.mkDerivation {
         inherit pname version;
 
         src = ./.;
-        makeFlags = ["PREFIX=${placeholder "out"}"];
+        makeFlags = ["PREFIX=${placeholder "out"}" "BIN_VERSION=${version}"];
         inherit nativeBuildInputs;
       };
     in {