about summary refs log tree commit diff stats
path: root/templates/c/flake.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-03-31 16:29:47 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-03-31 23:59:52 +0200
commit392a8dd604e7f7cac385f51fe083a78c8a7f9904 (patch)
tree60b0c41c0e0b535a593f86fccad22c69ff58991f /templates/c/flake.nix
parentchore(version): v0.2.0 (diff)
downloadflake-templates-392a8dd604e7f7cac385f51fe083a78c8a7f9904.tar.gz
flake-templates-392a8dd604e7f7cac385f51fe083a78c8a7f9904.zip
feat(c): Update to be in line with the my SOTA
Diffstat (limited to '')
-rw-r--r--templates/c/flake.nix (renamed from c/flake.nix)37
1 files changed, 28 insertions, 9 deletions
diff --git a/c/flake.nix b/templates/c/flake.nix
index 0eab217..cd4200c 100644
--- a/c/flake.nix
+++ b/templates/c/flake.nix
@@ -1,9 +1,16 @@
 {
-  description = "<Project description>";
+  description = "TODO";
 
   inputs = {
     nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
 
+    treefmt-nix = {
+      url = "github:numtide/treefmt-nix";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+      };
+    };
+
     # inputs for following
     systems = {
       url = "github:nix-systems/x86_64-linux"; # only evaluate for this system
@@ -24,29 +31,41 @@
     self,
     nixpkgs,
     flake-utils,
+    treefmt-nix,
     ...
   }:
     flake-utils.lib.eachDefaultSystem (system: let
       pkgs = nixpkgs.legacyPackages."${system}";
 
-      nativeBuildInputs = with pkgs; [valgrind];
-    in {
-      packages.default = pkgs.stdenv.mkDerivation {
+      nativeBuildInputs = with pkgs; [valgrind pandoc];
+      treefmtEval = import ./treefmt.nix {inherit treefmt-nix pkgs;};
+
+      pname = "TODO";
+      version = "0.1";
+
+      build = pkgs.stdenv.mkDerivation {
+        inherit pname version;
+
         src = ./.;
-        pname = "<pkgs_name>";
-        version = "0.1";
         makeFlags = ["PREFIX=${placeholder "out"}"];
         inherit nativeBuildInputs;
       };
-      apps.default = {
-        type = "app";
-        program = "${self.packages.${system}.default}/bin/<pkgs_name>";
+    in {
+      packages.default = build;
+      checks = {
+        inherit build;
+        formatting = treefmtEval.config.build.check self;
       };
+      formatter = treefmtEval.config.build.wrapper;
+
       devShells.default = pkgs.mkShell {
         packages = with pkgs; [
           cocogitto
         ];
         inherit nativeBuildInputs;
+        env = {
+          GCC_COLORS = "error=01;31:warning=01;35:note=01;36:caret=01;32:locus=01:quote=01";
+        };
       };
     });
 }